0
$\begingroup$

Rosanswers logo

Hi, I noticed that in my project every node with dynamic_reconfigure is rebuilt even if there is no file change. Is this a known behaviour of catkin? Is there anyway to prevent it?

Thanking you, Benzun

Edit: I thought I solved this issue but everytime i run dynamic reconfigure the headers are created again in the folder /devel/include/package_name.

I am using ros hydro on Ubuntu 12.04. I am just building the dynamic_reconfigure tutorial from http://wiki.ros.org/dynamic_reconfigure/Tutorials/HowToWriteYourFirstCfgFile

Everytime i run the build i get the following

Generating dynamic reconfigure files from cfg/Tutorial.cfg: /home/bpwiselybabu/drc_workspace/devel/include/dynamic_tutorials/TutorialConfig.h /home/bpwiselybabu/drc_workspace/devel/lib/python2.7/dist-packages/dynamic_tutorials/cfg/TutorialConfig.py

Even though I have not edited the cfg/Tutorial.cfg file

This does not happen with ros messages though.


Originally posted by Benny on ROS Answers with karma: 132 on 2014-05-15

Post score: 6


Original comments

Comment by Dirk Thomas on 2014-05-21:
This is not a known issue. If you want more help to figure out what is happening for you you might want to provide more information: Which version of ROS are you using? For which package do you experience the issue? What commands do you invoke, what is the actual output, what the expected?

Comment by joq on 2014-05-24:
Without more information, I don't see how anyone can help you.

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

I've seen this happen when the class name that is generated doesn't match the file name that generated it.

This is noted in the tutorial that you link to:

"NOTE: The third parameter should be equal to the cfg file name, without extension. Otherwise the libraries will be generated in every build, forcing a recompilation of the nodes which use them."


Originally posted by ahendrix with karma: 47576 on 2014-07-02

This answer was ACCEPTED on the original site

Post score: 7


Original comments

Comment by drewm1980 on 2015-10-22:
I had the same issue on ubuntu 14.04 / ros indigo. This solved it.

$\endgroup$
0
$\begingroup$

Rosanswers logo

We had the same problem but we fixed it by adding _catkin in the following line in the cfg file:

from dynamic_reconfigure.parameter_generator_catkin import *

I had converted an old package to catkin and had missed that you needed _catkin here.


Originally posted by TommyP with karma: 1339 on 2014-05-22

This answer was NOT ACCEPTED on the original site

Post score: 5


Original comments

Comment by Benny on 2014-05-22:
Similar issue I was upgrading an existing package in catkin. but I already made the change you suggested, yet it occurs.

Comment by TommyP on 2014-05-22:
I just tested to remove _catkin and then it re-generated the dynamic_reconfigure files each time I run catkin_make. I tested it on Hydro.

Comment by RaminYT on 2019-05-29:
This solved my problem (the parameter name was already matching the cfg name). Thanks a lot :)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.