0
$\begingroup$

Rosanswers logo

Hello,

I'm attempting to install and use fovis_ros, and I feel as though I'm missing something. I did the following in a top-level ROS workspace:

cd /src

sudo apt-get install ros-hydro-fovis

Apparently there's no binary package so I did a

git clone https://github.com/srv/fovis.git

This created

/src/fovis

/fovis

/fovis_ros

Then,

catkin_make

and I got

"The specified source space "/home/blah-blah-my-dirs/src/fovis/src" does not exist"

And indeed, ./fovis/fovis/src does not exist.

Reading here, I see "This stack contains two packages: libfovis and fovis_ros. The former contains a Makefile for downloading and building fovis, the latter contains the ROS wrapper for this library."

I was expecting that doing catkin_make would automagically go get libfovis and build it, but no soap.

Is this a bug, or a feature? :)

Thanks,

Rick

P.S. I also tried

sudo apt-get install libfovis,

and this installed fine, but still didn't help with building fovis_ros.


Originally posted by Rick Armstrong on ROS Answers with karma: 567 on 2014-05-10

Post score: 0


Original comments

Comment by Lili Meng on 2014-10-27:
I have the same problem after install libfovis.

CMake Error at /opt/ros/hydro/share/libfovis/cmake/libfovisConfig.cmake:141 (message): Project 'fovis_ros' tried to find library 'libfovis'. The library is neither a target nor built/installed properly. Did you compile project 'libfovis'?

Comment by Rick Armstrong on 2014-10-28:
Hi Lili,

It's been a while, but if I remember correctly,

  1. pulling the Miquel's latest libfovis drop as of May 11 (see below), and
  2. building libfovis in the top level of my ROS workspace fixed my problem.

Rick

Comment by Lili Meng on 2014-10-29:
Thanks a lot! It has been successfully compiled! :)

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hi Rick,

could you please try putting ros-hydro-libfovis? If that does not work try instead downloading libfovis in your ws from https://github.com/srv/libfovis There may be something wrong with the debian package.

Can you please tell me which ROS distro are you using?


Originally posted by Miquel Massot with karma: 1471 on 2014-05-10

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Rick Armstrong on 2014-05-11:
Miquel, I'm using hydro on Ubuntu 12.04 LTS. I installed ros-hydro-libfovis but fovis_ros still didn't find libfovis. I then downloaded the libfovis source to my ws as you suggested, and this fixed the problem. Next issue: compiling mono_depth_odometer.cpp fails, unable to find fovis_ros/FovisInfo.h

Comment by Rick Armstrong on 2014-05-11:
Also: thanks!

Comment by Miquel Massot on 2014-05-11:
I added a message generation dependency to fovis_ros. Please update your package -> git pull. Good catch!

Comment by Rick Armstrong on 2014-05-12:
That did the trick, thanks!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.