0
$\begingroup$

Rosanswers logo

Hi Everyone, I am running two turtlebots (kobuki) with gazebo1.9 and I provided command velocities to each turtlebot using “rostopic pub” command. I noticed that turtlebot keep moving after I killed the command velocity using “Control tab +c”. I am wondering if this anomaly is due to the inertia values for my wheels or something else Thanks for any help with this issue


Originally posted by Robert1 on ROS Answers with karma: 63 on 2014-05-02

Post score: 1


Original comments

Comment by Arkapravo on 2014-05-04:
Have faced similar problems with Roomba

Comment by Robert1 on 2014-05-05:
Somebody gave a tip to sent 0 command velocity. rostopic pub /cmd_vel geometry_msgs/Twist '[0.0, 0.0, 0.0]' '[0.0, 0.0, 0.0]'

That command stopped the turtlebot.

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

I believe that unless a value of zero gets published, then the last value is what is used by the bot. Killing the publication command doesn't force a value of zero to be published, so the bot continues with the last speed it received.


Originally posted by Kurt Leucht with karma: 486 on 2014-05-05

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Robert1 on 2014-05-05:
I agree with you. I will take this for final answer

$\endgroup$
0
$\begingroup$

Rosanswers logo

The gazebo plugin might not have a timeout on incoming commands when they stop being published it may continue to execute the last received command.


Originally posted by tfoote with karma: 58457 on 2014-05-04

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by Robert1 on 2014-05-05:
Hi Tfoote, In order to add a timeout on the incoming commands, Do i need to change the source code of the pluging? or is there another way to add a timeout? I installed Gazebo$gazebo-ros-pack from binaries and the turtlebot from source. For now, I send a 0 command velocity to stop the turtlebot. Thanks a lot for your help

Comment by dornhege on 2014-05-05:
You could look for a parameter that might enable this. If there isn't I'm sure a patch is appreciated.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.