0
$\begingroup$

Rosanswers logo

Hellow,

I'm tying to use Openni with my Xtion on fedora but until now no luck.

Fedora

UPDATE

I though it was time to update this topic concerning Fedora. I reinstalled my ros system from the stable repository given by @cottsay (Thanks a lot !) (and I hope I didn't install it wrong :S) and now I have the same issu for Openni and Openni 2.

Here is the error message when using roslaunch openni_launch openni_launch (or openni2_launch)

core service [/rosout] found
process[camera/camera_nodelet_manager-1]: started with pid [5425]
[ INFO] [1399810166.488640310]: Initializing nodelet with 4 worker threads.
process[camera/driver-2]: started with pid [5446]
[ERROR] [1399810166.563107584]: Failed to load nodelet [/camera/driver] of type [openni_camera/driver]: According to the loaded plugin descriptions the class openni_camera/driver with base class type nodelet::Nodelet does not exist. Declared types are  depth_image_proc/convert_metric depth_image_proc/disparity depth_image_proc/point_cloud_xyz depth_image_proc/point_cloud_xyzrgb depth_image_proc/register image_proc/crop_decimate image_proc/debayer image_proc/rectify image_rotate/image_rotate image_view/disparity image_view/image nodelet_tutorial_math/Plus pcl/BAGReader pcl/ExtractIndices pcl/NodeletDEMUX pcl/NodeletMUX pcl/PCDReader pcl/PCDWriter pcl/PassThrough pcl/PointCloudConcatenateDataSynchronizer pcl/PointCloudConcatenateFieldsSynchronizer pcl/ProjectInliers pcl/StatisticalOutlierRemoval pcl/VoxelGrid stereo_image_proc/disparity stereo_image_proc/point_cloud stereo_image_proc/point_cloud2
[FATAL] [1399810166.563287813]: Service call failed!
process[camera/debayer-3]: started with pid [5460]
process[camera/rectify_mono-4]: started with pid [5473]
process[camera/rectify_color-5]: started with pid [5492]
process[camera/rectify_ir-6]: started with pid [5505]
[camera/driver-2] process has died [pid 5446, exit code 255, cmd /opt/ros/hydro/lib/nodelet/nodelet load openni_camera/driver camera_nodelet_manager --no-bond ir:=ir rgb:=rgb depth:=depth depth_registered:=depth_registered projector:=projector __name:=driver __log:=/home/malcolm/.ros/log/ef2267be-d904-11e3-9dd7-dc85de5a9ca4/camera-driver-2.log].
log file: /home/malcolm/.ros/log/ef2267be-d904-11e3-9dd7-dc85de5a9ca4/camera-driver-2*.log
process[camera/depth_rectify_depth-7]: started with pid [5525]

Here are my installed packages :

openni.x86_64                         1.3.2.1-9.fc20             @updates          
openni-devel.x86_64                   1.3.2.1-9.fc20             @updates          
openni-examples.x86_64                1.3.2.1-9.fc20             @updates          
openni-nite.x86_64                    1.4.1.2-4.fc19             @rpmfusion-nonfree
openni-nite-devel.x86_64              1.4.1.2-4.fc19             @rpmfusion-nonfree
openni-primesense.x86_64              5.0.3.3-7.fc20             @fedora           
openni2.x86_64                        2.2.0.33-4.fc20            @smd-ros-staging  
openni2-devel.x86_64                  2.2.0.33-4.fc20            @smd-ros-staging 

my lsusb :

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 13d3:5165 IMC Networks 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 1d27:0601 ASUS 
Bus 003 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

and my dmesg :

[ 7247.390501] usb 3-3: New USB device strings: Mfr=5, Product=4, SerialNumber=0
[ 7247.390503] usb 3-3: Product: PrimeSense Device
[ 7247.390504] usb 3-3: Manufacturer: PrimeSense
[ 7247.602073] ALSA sound/usb/mixer.c:1304 usb_audio: Warning! Unlikely big volume range (=4181), cval->res is probably wrong.
[ 7247.602077] ALSA sound/usb/mixer.c:1308 usb_audio: [3] FU [Mic Capture Volume] ch = 2, val = 0/12544/3
[ 7247.605452] ALSA sound/usb/mixer.c:1304 usb_audio: Warning! Unlikely big volume range (=4181), cval->res is probably wrong.
[ 7247.605454] ALSA sound/usb/mixer.c:1308 usb_audio: [3] FU [Mic Capture Volume] ch = 1, val = 0/12544/3
[ 7247.605841] usbcore: registered new interface driver snd-usb-audio

Question about installed openni-camera :

Sadly it seems like I have one of them:

yum list ros-hydro-openni-camera
Modules complémentaires chargés : langpacks, refresh-packagekit
smd-ros-shadow-fixed                                     | 2.9 kB     00:00     
smd-ros-staging                                          | 2.9 kB     00:00     
Package installed
ros-hydro-openni-camera.x86_64        1.9.2-0.fc20         @smd-ros-shadow-fixed

I did NOT have reinstalled openni2-camera and os I did. Now Those packages are on my system :

ros-hydro-openni-camera.x86_64         1.9.2-0.fc20        @smd-ros-shadow-fixed
ros-hydro-openni-launch.x86_64         1.9.5-0.fc20        @smd-ros-shadow-fixed
ros-hydro-openni2-camera.x86_64        0.1.2-0.fc20        @smd-ros-shadow-fixed

For info, this is my primesense package :

openni-primesense.x86_64                 5.0.3.3-7.fc20                  @fedora

I have openni2_launch in my workspace, so everything should be fine but I still have erreur when using roslaunch openni2_launch...

[ERROR] [1399831998.457249429]: Failed to load nodelet [/camera/points_xyzrgb_depth_rgb] of type [depth_image_proc/point_cloud_xyzrgb]: Failed to load library /opt/ros/hydro/lib//libdepth_image_proc.so. Make sure that you are calling the PLUGINLIB_EXPORT_CLASS macro in the library code, and that names are consistent between this macro and your XML. Error string: Could not load library (Poco exception = dlopen: cannot load any more object with static TLS)
[FATAL] [1399831998.457510596]: Service call failed!
[ERROR] [1399831998.510943554]: Failed to load nodelet [/camera/points_xyz_depth_rgb] of type [depth_image_proc/point_cloud_xyz]: MultiLibraryClassLoader: Could not create object of class type depth_image_proc::PointCloudXyzNodelet as no factory exists for it. Make sure that the library exists and was explicitly loaded through MultiLibraryClassLoader::loadLibrary()
[FATAL] [1399831998.511399744]: Service call failed!
[camera/points_xyzrgb_depth_rgb-5] process has died [pid 13798, exit code 255, cmd /opt/ros/hydro/lib/nodelet/nodelet load depth_image_proc/point_cloud_xyzrgb /camera_nodelet_manager rgb/image_rect_color:=rgb/image_rect rgb/camera_info:=rgb/camera_info depth_registered/image_rect:=depth/image_rect_raw depth_registered/points:=depth/points_xyzrgb __name:=points_xyzrgb_depth_rgb __log:=/home/malcolm/.ros/log/e59a47e2-d937-11e3-a5be-dc85de5a9ca4/camera-points_xyzrgb_depth_rgb-5.log].
log file: /home/malcolm/.ros/log/e59a47e2-d937-11e3-a5be-dc85de5a9ca4/camera-points_xyzrgb_depth_rgb-5*.log
[camera/points_xyz_depth_rgb-6] process has died [pid 13812, exit code 255, cmd /opt/ros/hydro/lib/nodelet/nodelet load depth_image_proc/point_cloud_xyz /camera_nodelet_manager image_rect:=depth/image_rect_raw points:=depth/points_xyz __name:=points_xyz_depth_rgb __log:=/home/malcolm/.ros/log/e59a47e2-d937-11e3-a5be-dc85de5a9ca4/camera-points_xyz_depth_rgb-6.log].
log file: /home/malcolm/.ros/log/e59a47e2-d937-11e3-a5be-dc85de5a9ca4/camera-points_xyz_depth_rgb-6*.log

Honestly though, it's two in the morning and I didn't check this error at all because it's too late for me to think correctly now, and I'll check tomorrow so I'm sorry if it got a trivial error ^^.

EDIT 2 :

Ubuntu

On Ubuntu when I try to use openni1 I have this error :

[ INFO] [1399272310.815857984]: Number devices connected: 1
[ INFO] [1399272310.815941482]: 1. device on bus 003:04 is a PrimeSense Device (601) from PrimeSense (1d27) with serial id ''
[ INFO] [1399272310.816924289]: Searching for device with index = 1
process[camera/depth_rectify_depth-7]: started with pid [19112]
process[camera/depth_metric_rect-8]: started with pid [19129]
process[camera/depth_metric-9]: started with pid [19143]
process[camera/depth_points-10]: started with pid [19157]
process[camera/register_depth_rgb-11]: started with pid [19171]
/opt/ros/hydro/lib/nodelet/nodelet: symbol lookup error: /home/ros/hydro_ws/catkin_ws/devel/lib//libopenni_nodelet.so: undefined symbol: _ZN14openni_wrapper12OpenNIDevice15getSerialNumberEv

My lsusb then :

ros@ros-K56CM:~$ lsusb
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 003 Device 004: ID 1d27:0601  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 13d3:5165 IMC Networks 

I think this is the part that concern the Xtion with dmesg in ubuntu :

[ 4832.060454] usb 3-3: new high-speed USB device number 3 using xhci_hcd
[ 4832.082684] usb 3-3: New USB device found, idVendor=1d27, idProduct=0601
[ 4832.082692] usb 3-3: New USB device strings: Mfr=5, Product=4, SerialNumber=0
[ 4832.082697] usb 3-3: Product: PrimeSense Device
[ 4832.082701] usb 3-3: Manufacturer: PrimeSense
[ 4839.290644] 3:2:1: cannot get freq at ep 0x84
[ 4894.337502] 3:1: cannot get min/max values for control 2 (id 3)
[ 4896.632039] usb 3-3: USB disconnect, device number 3
[ 4896.632043] 3:1: cannot get min/max values for control 2 (id 3)
[ 4896.632489] usbcore: registered new interface driver snd-usb-audio
[ 4908.933895] usb 3-3: new high-speed USB device number 4 using xhci_hcd
[ 4908.956196] usb 3-3: New USB device found, idVendor=1d27, idProduct=0601
[ 4908.956203] usb 3-3: New USB device strings: Mfr=5, Product=4, SerialNumber=0
[ 4908.956207] usb 3-3: Product: PrimeSense Device
[ 4908.956210] usb 3-3: Manufacturer: PrimeSense
[ 4913.962188] 4:2:1: cannot set freq 48000 to ep 0x84
[ 4913.968038] usb_audio: Warning! Unlikely big volume range (=4181), cval->res is probably wrong.
[ 4913.968041] usb_audio: [3] FU [Mic Capture Volume] ch = 1, val = 0/12544/3
ros@ros-K56CM:~$ 

Any help on it will be appreciated


Originally posted by Maya on ROS Answers with karma: 1172 on 2014-05-02

Post score: 1


Original comments

Comment by Hansg91 on 2014-05-02:
Did you try the sample of openni? Does that sample work?

Comment by Maya on 2014-05-02:
No I didn't... Where are they ?

Comment by Hansg91 on 2014-05-02:
For me they are at openni2/Samples/Bin ;)

Comment by Maya on 2014-05-02:
Hum... I installed openni through apt-get (or yum on my fedora) and I'm not able to find that folder you said -_-... What is the path to that folder when installed that way ? I'm sorry it's such a stupid question but I couldn't find it. I found something and updated y question =)

Comment by Hansg91 on 2014-05-03:
Seems it doesn't get connected through usb. What do you see in dmesg when you connect the xtion? Also the samples can be downloaded from openni.org (they are in the SDK).

Comment by Maya on 2014-05-04:
I'll try to put dmesg in Fedora as soon as I can (I use Ubuntu at work and Fedora at home). The openni website is always down for me :/ I put every information asked =D

Comment by Hansg91 on 2014-05-05:
Sorry, can't help any further :) no idea..

Comment by Maya on 2014-05-05:
Arf thanks anyway =P

Comment by cottsay on 2014-05-10:
@Maya, what version of Fedora are you using and are you using the Fedora package for the OpenNI libraries or a source build?

Also, please try installing the RPM package openni-examples and then run the command NiViewer with your Xtion plugged in, and see if it works...

Comment by Maya on 2014-05-11:
I'm using Fedora 20 and Openni libraries. I'll try installing openni-example as soon as possible.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

This may seem like a silly question, but are you sure you have ros-hydro-openni-camera and ros-hydro-openni2-camera installed? It really acts like they're missing...


Originally posted by cottsay with karma: 311 on 2014-05-11

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by Maya on 2014-05-11:
Not so silly since I reinstalled everything. =) See new update.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.