0
$\begingroup$

Rosanswers logo

I am installing on Ubuntu trying to get through the steps and have tried to install on 2 different machines. When I try to install the certs using wget ( h t t p) //packages.ros.org/ros.key -o | sudo apt-key add - I get

no valid OpenPGP data found

When I try to install ros with sudo apt-get-install-ros-base i get:

E: Unable to locate ros-hydro-ros-base

I think everything else is configured. Anyone point me in the right direction here.


Originally posted by robauto on ROS Answers with karma: 21 on 2014-04-26

Post score: 2

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

It sounds like you're having trouble adding the key for the ROS repositories. You may want to try downloading and adding the key in separate steps:

wget http://packages.ros.org/ros.key
sudo apt-key add ros.key

Then you should be able to install ROS by running:

sudo apt-get update
sudo apt-get install ros-hydro-ros-base

Originally posted by ahendrix with karma: 47576 on 2014-04-26

This answer was ACCEPTED on the original site

Post score: 3


Original comments

Comment by Felix on 2014-06-06:
Hi Ahendrix,

I am also blocked by the same problem. I have tried what you proposed. Got the following result,

felix@felix-notebook:~$ wget http://packages.ros.org/ros.key -o - | sudo apt-key add - gpg: no valid OpenPGP data found. felix@felix-notebook:~$ wget http://packages.ros.org/ros.key --2014-06-06 16:36:23-- http://packages.ros.org/ros.key Resolving packages.ros.org (packages.ros.org)... 140.211.166.134 Connecting to packages.ros.org (packages.ros.org)|140.211.166.134|:80... connected. HTTP request sent, awaiting response... 200 OK Length: 1162 (1.1K) [application/pgp-keys] Saving to: `ros.key.4'

100%[======================================================================================================>] 1,162 --.-K/s in 0s

2014-06-06 16:36:23 (54.9 MB/s) - `ros.key.4' saved [1162/1162]

felix@felix-notebook:~$ sudo apt-key add ros.key gpg: no valid OpenPGP data found.

Appreciate it very much if you could give me any idea to solve this.

Comment by ahendrix on 2014-06-06:
Sorry; you comment is completely unreadable without formatting. Can you please ask this as a new question?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.