0
$\begingroup$

Rosanswers logo

I am attempting to spawn controllers but interactions with controller_manager seem to hang.

  1. when I attempt to launch my controllers I see the following after a timeout:

[INFO] [WallTime: 1398097365.560001] Controller Spawner: Waiting for service controller_manager/load_controller [WARN] [WallTime: 1398097395.567543] Controller Spawner couldn't find the expected controller_manager ROS interface. [gripper/controller_spawner-1] process has finished cleanly log file: /home/user/.ros/log/57c14baa-c96f-11e3-b22a-c81f6621927d/gripper-controller_spawner-1*.log

  1. Subsequently, if I attempt to merely list controllers/types the call hangs until I kill the process:

rosrun controller_manager controller_manager list

Anyone have any tips on what I am doing wrong? I have confirmed that ros_control and ros_controllers are installed.

Thanks in advance.


Originally posted by b3l33 on ROS Answers with karma: 113 on 2014-04-21

Post score: 0


Original comments

Comment by ahendrix on 2014-04-21:
Do you have a control process running? Can you see the controller_manager service with rosservice list ?

Comment by b3l33 on 2014-04-21:
No, it does not appear in the list of services....

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

It sounds like you don't have a control loop running.

The controller_manager paradigm has two components, the control loop itself, which reads data and sends commands to the actuators, and which has loadable controllers through a service, and the controller_manager, which calls that service to load and unload controllers.

In your case, it sounds like your control loop isn't running. It's hard to say more without knowing what kind of robot you're trying to control and which nodes are already running.


Originally posted by ahendrix with karma: 47576 on 2014-04-21

This answer was NOT ACCEPTED on the original site

Post score: 2

$\endgroup$
0
$\begingroup$

Rosanswers logo

I found my mistake. I had a type-o in my URDF. I was using an incorrect tag in the gazebo plugin namespace element. Namely, I had

<gazebo>
  <plugin name="gazebo_ros_control" filename="libgazebo_ros_control.so">
    <robot_namespace>/gripper</robot_namespace>
  </plugin>
</gazebo>

When I should have had

<gazebo>
  <plugin name="gazebo_ros_control" filename="libgazebo_ros_control.so">
    <robotNamespace>/gripper</robotNamespace>
  </plugin>
</gazebo>

Originally posted by b3l33 with karma: 113 on 2014-04-21

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.