Rosanswers logo

Hello everybody!

I am trying to implement the move_base node. However, I am not using a map. If I start the move_base node, it loads all the config files, but keeps waiting for a map. Is there a way to start the node without a map? If I use my odometry frame as fixed frame it should work as far as I know. I followed the navigation stack tutorial to set up my robot, I have a laser source, the correct transformation from base_link to laser and an odometry node which provides the transformation from odom to base_link.

The following shows my config files:


obstacle_range: 0.5
raytrace_range: 3.0
#footprint: [[x0, y0], [x1, y1], ... [xn, yn]]
robot_radius: 0.18
inflation_radius: 0.25

observation_sources: laser_scan_sensor

laser_scan_sensor: {sensor_frame: laser, data_type: LaserScan, topic: scan, marking: true, clearing: true}


global_frame: /odom
robot_base_frame: /base_link
update_frequency: 5.0
static_map: false


global_frame: /odom
robot_base_frame: /base_link
update_frequency: 5.0
publish_frequency: 2.0
static_map: false
rolling_window: true
width: 6.0
height: 6.0
resolution: 0.05


 max_vel_x: 0.45
 min_vel_x: 0.1
 max_rotational_vel: 1.0
 min_in_place_rotational_vel: 0.4

 acc_lim_th: 3.2
 acc_lim_x: 2.5
 acc_lim_y: 2.5

 holonomic_robot: true



  <node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
   <rosparam file="$(find dm_navigation)/costmap_common_params.yaml" command="load" ns="global_costmap" />
   <rosparam file="$(find dm_navigation)/costmap_common_params.yaml" command="load" ns="local_costmap" />
   <rosparam file="$(find dm_navigation)/local_costmap_params.yaml" command="load" />
   <rosparam file="$(find dm_navigation)/global_costmap_params.yaml" command="load" />
   <rosparam file="$(find dm_navigation)/base_local_planner_params.yaml" command="load" />

My tf-tree shows odom->base_link->laser

I had a look at the parameters of move_base, but could not find any parameter to turn map on/off. Additionally, the topics for the robot footprint, enlarged obstacles are not published and the robot does not react to navigation commands. This tells me, that the move base node is not ready yet.

If anyone of you knows a trick to use move_base without map, or sees any error in my config files, any help would be appreciated.

Thank you in advance for your help!

Regards, steve

Originally posted by optimus on ROS Answers with karma: 51 on 2014-04-19

Post score: 5

Original comments

Comment by Moda on 2014-07-28:
Did you succeed to solve your issue? I got the same


1 Answer 1


Rosanswers logo

You have incomplete defenition for global costmap. If it is not static, then you have to define rolling_window=true and width, height and resolution parameters, as you do for local costmap.

Originally posted by Mike Charikov with karma: 123 on 2014-04-20

This answer was ACCEPTED on the original site

Post score: 0


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.