0
$\begingroup$

Rosanswers logo

when i enter rosrun rviz rviz in terminal the following appears

[ INFO] : rviz version 1.10.14

[ INFO]: compiled against OGRE version 1.7.4 (Cthugha)

I use amd radeon HD 8***M series

I tried to uninstall OGRE 1.7.4; the uninstall of it contain the uninstall of rviz hydro, the install of hydro rviz contain the install of OGRE 1.7.4. how could I solve such a problem. How could I use hydro rviz

Anyone knows how to solve such a problem? thank you!!!!


Originally posted by Crystal on ROS Answers with karma: 1 on 2014-04-14

Post score: 0


Original comments

Comment by Ken_in_JAPAN on 2014-04-14:
Could you tell us why you are uninstalling OGRE 1.7.4?

Comment by Crystal on 2014-04-15:
cause i came across some problems when i run rviz and i tried some method to solve them. when i tried this one, I find such a thing and I wonder the reason for that.

Comment by Ken_in_JAPAN on 2014-04-15:
@Crystal: Did you have same error that is described on this page ( http://answers.ros.org/question/150801/segmentation-fault-at-rosrun-rviz-rviz/ )? If so, I gave up and reinstalled both ROS and Ubuntu. Sorry!! If you want to ask the question, you should post it again. Question is changed.

Comment by Crystal on 2014-04-15:
oh....more or less the same...sometimes I can use some times not....thank you for your advice! But I have reinstalled both of them 2 times....I think it is the problem of my graphic card driver. I will try some other methods, if they will not work. I think I should reinstall them again...thank you~

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

OGRE is a 3D graphics library that is used by Rviz; you can't have rviz without it. This is why the package manager installs it when you install rviz.

If you want to use a different version of OGRE, you can build rviz from source.


Originally posted by ahendrix with karma: 47576 on 2014-04-14

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by Crystal on 2014-04-15:
thank you!! and I have another problem that when I open a file in rviz it shut down. why is that, how could I solve such a problem? thank you for your help!

Comment by ahendrix on 2014-04-16:
You should ask this as a new question, and include the command-line arguments you're passing to rviz, and possibly a link to the file you're trying to open.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.