0
$\begingroup$

Rosanswers logo

I came across a segmentation fault while trying rosrun rviz rviz. This issue has been discussed on this web( http://answers.ros.org/question/11376/rviz-segmentation-fault-at-launch/ ), but I think that essential issue has been not solved. The solution in the comment and the answer was to delete all of file in ~/.rviz. I also deleted all of files as I follow the instruction. But, the error doesn't go out.

[ INFO]rviz version 1.10.14
[ INFO]compiled against OGRE version 1.7.4 (Cthugha)
[ INFO]Stereo is NOT SUPPORTED
[ INFO]OpenGl version: 2.1 (GLSL 1.2)
Segmentation fault

I have checked the article (http://wiki.ros.org/rviz/Troubleshooting). I can't find the way to solve the issue on the article. Could anyone give me clues? Thank you in advance!


Originally posted by Ken_in_JAPAN on ROS Answers with karma: 894 on 2014-04-08

Post score: 0

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

The type of graphics card you use always is crucial when looking at rviz crashes (you can edit your answer to add that information). The rule of thumb is: "Nvdidia GPUs with propietary drivers generally work well, others might crash occasionally (or always in a absolute worst case)". With your GPU and driver known, I´d recommend googling something like "rviz crashes ros answers [your graphics card type]". There are tons of posts on rviz crashes on ROS Answers and it´s likely that there will be useful information in some of them.


Originally posted by Stefan Kohlbrecher with karma: 24361 on 2014-04-08

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Ken_in_JAPAN on 2014-04-08:
@Stefan Kohlbrecher: Thank you for your advice! I will check it out tomorrow. Sorry, here is at midnight.

Comment by Ken_in_JAPAN on 2014-04-08:
@Stefan Kohlbrecher: I was looking over the article on the web(http://wiki.ros.org/rviz/Tutorials/Rviz%20in%20Stereo). Do you think that this contents connects with my issues?

Comment by Stefan Kohlbrecher on 2014-04-08:
Unless you try something with stereo mode, no. I assume you installed from .deb packages?

Comment by Ken_in_JAPAN on 2014-04-09:
I don't make sense, I was googling to search for the cause and how to fix it. I also tried the method on the web (https://github.com/ros-visualization/rviz/issues/713), but segmentation fault didn't go out. I will reinstall.

$\endgroup$
0
$\begingroup$

Rosanswers logo

Hi all,

I spent a load of time fixing these issues. What I realised is that Virtualbox is being a nasty little rascal with it's 3d Acceleration.

Switching if off fixed these issues for me.

Switch off your VM Just go to the VM Settings -> Display -> Uncheck Enable 3D Acceleration. Start your VM again. Rejoice!


Originally posted by sachitv with karma: 51 on 2017-04-16

This answer was NOT ACCEPTED on the original site

Post score: 2


Original comments

Comment by iguanaistic on 2017-04-21:
Thank you! This worked for me.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.