0
$\begingroup$

Rosanswers logo

I use the map server, a global and local plan is created and I also get cmd_vel outputs. This is a geometry_msgs/Twist output with a value linear.x for the speed and angular.z for the speed around the z-axis -> I generate a odom message from this message to simulate a input for the navigation stack... noticeable is that the value for the speed around the z-axis changes a lot, also from negative to positive values and back... and after some time I get this error!? I'm glad about any suggestions or help (I use ros hydro)

Best regards Matthias


Originally posted by moejoegoe on ROS Answers with karma: 1 on 2014-03-30

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

The short answer is that navfn and base_local_planner aren't suitable for ackermann type robots. The planners don't take into account the kinematic constraints (minimum turning radius, can't turn in place) of the robot, and therefore can generate plans that aren't executable by the robot.

It is possible to use the sbpl_lattice_planner as the global planner, but there isn't a great local planner for ackermann type robots yet.

It's difficult to say what is wrong with your specific simulation without more details. It sounds like the local planner is failing to find a valid path, but without knowing the specifics of your configuration, it's hard to say whether that's a problem with your costmaps, with the local planner configuration, with how you're running the simulation, or something else entirely.


Originally posted by ahendrix with karma: 47576 on 2014-03-30

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.