0
$\begingroup$

Rosanswers logo

Hello to all!

A few months ago, I connected Arduino to ROS fuerte using rosserial without problems. However, now I'm trying to reproduce it in ROS groovy and I always get the same error.

I am working with Ubuntu 12.04, ROS Groovy, Arduino 1.0.5, rosserial-groovy-devel and both Arduino Uno and Arduino Mega.

I do these commands:

Window 1:

sudo ./Arduino/arduino

Open Hello World example.

Select Controller Arduino Uno/Mega.

Select Serial Port /dev/ttyACM0.

Load code.

Window 2:

roscore

Window 3:

sudo chmod a+rw /dev/ttyACM0

rosrun rosserial_python serial_node.py /dev/ttyACM0

And I get this error:

[INFO] [WallTime: 1394533587.406466] ROS Serial Python Node

[INFO] [WallTime: 1394533587.419060] Connecting to /dev/ttyACM0 at 57600 baud

[ERROR] [WallTime: 1394533590.332723] Creation of publisher failed: unpack requires a string argument of length 4

[ERROR] [WallTime: 1394533591.328157] Tried to publish before configured, topic id 125

Anyone can help me?

Thanks in advance!


Originally posted by Jota on ROS Answers with karma: 13 on 2014-03-11

Post score: 0

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

Try removing and remaking your ros_lib.


Originally posted by tonybaltovski with karma: 2549 on 2014-03-11

This answer was ACCEPTED on the original site

Post score: 4

$\endgroup$
0
$\begingroup$

Rosanswers logo

Solved!

There was a problem in the installation of ros_lib due to Arduino sketchbook permissions.

Thanks!


Originally posted by Jota with karma: 13 on 2014-03-11

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.