0
$\begingroup$

Rosanswers logo

Hi,

I am trying to use openni_tracker. I have ros-fuerte-openni* installed. roslaunch openni_launch openni.launch is working properly and I can see the image in rviz. However, when I run rosrun openni_tracker openni_tracker, initially there was the following error.

Find user generator failed: This operation is invalid!

I googled for the solution to this problem and was instructed to install NITE-bin-dev-linux-64-v1.5.2.23. Now the error has change to the following.

Find user generator failed: Can't create any node of the requested type!

Any help?


Originally posted by Latif Anjum on ROS Answers with karma: 79 on 2014-02-18

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I see you posted new answers here and here. Just FYI, that's really not how this site should work; the answers are really for answers, not new questions.

Based on all of your information I have several pieces of advice. First, I already mentioned you should update NITE on one of your comments. After seeing this question, I see you already did that. On Fuerte and 12.04, I just tried openni_tracker with NITE versions 1.5.2.23 and 1.5.2.21 and it worked with both. During my testing I noticed that if I run openni_tracker before starting up the Kinect/Asus with openni_launch, I get the same error you are seeing. So first hint, make sure the device is running and publishing point clouds before starting the tracker.

Second hint: based on the second comment I linked above, you are getting a bunch of ELFCLASS warnings in the output of niReg -l. This sounds to me like you installed the x64 version of NITE, but you are on an x86 system. Try installing NITE-Bin-Dev-Linux-x86-v1.5.2.23 instead.


Originally posted by jarvisschultz with karma: 9031 on 2014-02-19

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Latif Anjum on 2014-02-19:
Thank you sir. Your suggestion to install NITE for x86 worked. Sorry for posting on multiple questions, will be careful in future.

Comment by gaussian on 2015-01-07:
@jarvisschultz Please tell me a solution for this error InitFromXml failed: Can't create any node of the requested type! I get this if I run openni_tracker .

Comment by anilmullapudi on 2016-07-18:
i was getting same error, InitFromXml failed: Can't create any node of the requested type! any clue how to resolve this please

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.