0
$\begingroup$

Rosanswers logo

In tutorial :

http://wiki.ros.org/urdf/Tutorials/Parse%20a%20urdf%20file

When I run:

~/catkin_ws$ ./devel/lib/testbot_description/parser /src/testbot_description/urdf/my_robot.urdf

I get:

[ERROR] [1391452425.205963339]: Could not open file [/src/testbot_description/urdf/my_robot.urdf] for parsing.
[ERROR] [1391452425.206094879]: Failed to parse urdf file

I checked in the directories, both files are already present but still error! Kindly help!

My Ros: Hydro My OS: Ubuntu 12.04 LTS


Originally posted by mudassar on ROS Answers with karma: 22 on 2014-02-03

Post score: 0


Original comments

Comment by hsu on 2014-02-03:
what do you see when you run "ls /src/testbot_description/urdf/my_robot.urdf"?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

There is a dot missing in the second tutorial.

From your catkin workspace, run: ./devel/lib/testbot_description/parser ./src/testbot_description/urdf/my_robot.urdf

It worked for me.


Originally posted by mudassar with karma: 22 on 2014-02-09

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.