0
$\begingroup$

Rosanswers logo

I have rviz crash

[rviz-5] process has died [pid 26833, exit code -11, cmd /opt/ros/groovy/lib/rviz/rviz -d /home/user/catkin_ws/src/semantic_navigation/rviz_config_test.rviz __name:=rviz __log:=/home/user/.ros/log/b2dfc712-8a10-11e3-b737-3c970e43a294/rviz-5.log].

when I try to add GridCells: topic: move_base_node/local_costmap/anything from here eg. obstacles

my parameters:

local_costmap:
publish_voxel_map: true
global_frame: /odom
robot_base_frame: /base_link
update_frequency: 5.0
publish_frequency: 5.0
static_map: false
rolling_window: true
width: 15.0
height: 15.0
resolution: 0.05
origin_x: 0.0
origin_y: 0.0

edit 1: LaserScan also crashes rviz

edit 2: I run rviz with optirun and the error does not occure when adding LaserScan, but error from local_costmap remains.


Originally posted by BP on ROS Answers with karma: 176 on 2014-01-30

Post score: 0


Original comments

Comment by Ander on 2014-01-30:
Same problem started to happen to me this week. While visualizing the navigation in Rviz, it crashes and sometimes (not always) says "malloc(): memory corruption". More Info: ubuntu 12.04, ros groovy, rviz version 1.9.34 , OGRE version 1.7.4, OpenGl version: 4.2. Nvidia driver 304.116 (Quadro 600)

Comment by Angus on 2014-01-31:
I'm getting new segfaults from trying to display LaserScan messages in Rviz too. Was working well last week. rviz version 1.9.34. OGRE version 1.7.4 (Cthugha). OpenGl version: 3 (GLSL 1.3). Intel Hashwell Video driver. Works well in Hydro still! Just not Groovy.

Comment by Ander on 2014-02-02:
Today I made another test. Instead of using the rviz binary installed with groovy distro, I downloaded the source code of rviz groovy-devel branch from github, built it and, after running, same problem happens: Segmentation fault (core dumped).

Comment by BP on 2014-02-03:
I'm also getting errors while trying to display LaserScan

Comment by oleo80 on 2014-02-03:
I also have the same problem on my new PC with Intel i7 Haswell. Rviz crashes after showing the laserscan message. PS: I have the same configuration of Angus (RVIZ 1.9.34. OGRE 1.7.4 OpenGl 3 (GLSL 1.3). Intel Hashwell Video driver.

Comment by BP on 2014-02-03:
https://github.com/ros-visualization/rviz/issues/713

Comment by BP on 2014-02-05:
i've updated question and added how i got rviz to work with LaserScan

Comment by Ander on 2014-02-05:
I downloaded previous rviz versions in order to figure out which is the last version that works. With rviz 1.9.32 I have no problems at all. After this version, both 1.9.33 and 1.9.34 crash.

Comment by BP on 2014-02-06:
how did u make it? when i try to catkin_make rviz 1.9.32 it says

/home/wildbaker/catkin_ws/src/rviz-1.9.32/src/rviz/yaml_config_reader.cpp: In member function ‘void rviz::YamlConfigReader::readStream(rviz::Config&, std::istream&, const QString&)’:

/home/wildbaker/catkin_ws/src/rviz-1.9.32/src/rviz/yaml_config_reader.cpp:63:12: error: ‘class YAML::Parser’ has no member named ‘GetNextDocumen

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I installed rviz1.9.35 from https://github.com/ros-visualization/rviz/tree/groovy-devel and rviz don't crash anymore when I add LaserScan


Originally posted by scarlett with karma: 170 on 2014-02-27

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by BP on 2014-03-19:
finally did it, i had problem with yaml. I end up with 1.9.32 working properly.

Comment by Kamiccolo on 2014-03-27:
@Gargamel, could You please elaborate more on Your exact problem and solution, please?

Comment by BP on 2014-03-27:
there was a bug: https://github.com/ros-visualization/rviz/issues/713

Comment by Kamiccolo on 2014-03-27:
@Gargamel, oh, ok, thanks. Waiting for the fixed version to appear in repository :}

Comment by BP on 2014-03-27:
there is (not in ubuntu's propably, but on github). You can download old working (1.9.32) or new working (1.9.35) version (If you're groovy user) and build it from source ( I had problems with old YAML libraries linking but building new rviz in debug worked for me-dunno why)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.