0
$\begingroup$

Rosanswers logo

Hey guys, I am new to ros and try to learn it by going through the beginner tutorial. However, when I tried typing the code "rosrun turtlesim turtlesim_node" provided in "Understandingnodes" part of the tutorial, the turtlesim window just flicked and then disappeared. I got the error message:

[ INFO] [1390367521.100598911]: Starting turtlesim with node name /turtlesim
[ INFO] [1390367521.107999703]: Spawning turtle [turtle1] at x=[5.544445], y=[5.544445], theta=[0.000000]
/opt/ros/hydro/lib/turtlesim/turtlesim_node: symbol lookup *****error: /opt/ros/hydro/lib/libroscpp.so: undefined symbol: _ZN3ros6HeaderC1Ev*****

I simply cannot do anything with the turtle since I can't see the window at all. Do you guys have any idea or suggestion? Thanks.


Originally posted by mrq44106 on ROS Answers with karma: 3 on 2014-01-21

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Just a couple of minutes ago I also had some weird symbol lookup errors, too (After pulling some updates with the update manager).

sudo apt-get install -f

and

sudo apt-get autoremove

together with erasing build dirs and rebuilding in my workspace by (in the catkin_ws folder:)

rm -r devel
rm -r build
catkin_make

solved the issue....


Originally posted by Wolf with karma: 7555 on 2014-01-21

This answer was ACCEPTED on the original site

Post score: 6


Original comments

Comment by mrq44106 on 2014-01-22:
The turtlesim window shows up after trying your instructions. Thanks a lot!

Comment by Alvaro Salcedo on 2015-09-11:
i have done the same and I can not fix it. Any ideas? The problem is the same..

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.