0
$\begingroup$

Rosanswers logo

Good afternoon partners.

I've just installed this morning Rasbpian/Groovy on a second raspberry of mine.

When I follow the instructions to get "rosserial" on

http://wiki.ros.org/rosserial_arduino/Tutorials/Arduino%20IDE%20Setup

everything goes well. BUT :

When I arrive to the step Adding Custom Messages(Generating Message Header File) on

http://wiki.ros.org/rosserial_arduino/Tutorials/Adding%20Custom%20Messages

and try to generate the header file invoking

rosrun rosserial_client make_library.py ~/sketchbook/libraries My_Package

I'm given : [rosrun] Couldn't find executable named make_library.py below /home/pi/catkin_ws/install/share/rosserial_client

Taking a look into ~/catkin_ws/install/share/rosserial_client/src I have only the "ros_lib" folder and the "rosserial_client" folder, wich includes "make_library.py and init.py", is missing.

Source : https://github.com/ros-drivers/rosserial/tree/hydro-devel/rosserial_client/src/rosserial_client

I don't know if it could be a forgetting updating repo or something. I just wanted to feedback it.

Thanks

EDIT 1 : I have done the next

cp -r ~/catkin_ws/src/rosserial/rosserial_client/src/rosserial_client/ /catkin_ws/install/share/rosserial_client/src/

Now I can execute rosrun rosserial_client make_library.py ~/sketchbook/libraries My_Package and to get the header file to my new message types.

I just wanted to share this with the community beacuse it seems that during the compiling of rosserial with catkin_make ... make_library.py is missing.

I hope this could help you in the futuro

Thanks for reading

EDIT 2: This solution does not work now. Now if I invoque "rosrun rosserial_client make_library.py ~/sketchbook/libraries My_Package", it seems that it does nothing because it does not create the header. I don´t know what can we do ..Thanks


Originally posted by 4LV4R0 on ROS Answers with karma: 70 on 2014-01-17

Post score: 0


Original comments

Comment by ahendrix on 2014-02-13:
This looks like a bug in rosserial_client and should probably be reported against their bugtracker.

Comment by 4LV4R0 on 2014-02-13:
Thanks ahendrix for your interest. The problem now is that when I type "rosrun rosserial_client make_library.py ~/sketchbook/libraries My_Package" it´s like nothing happens ... Where can i report this ?

Comment by ahendrix on 2014-02-13:
The issue tracker for rosserial is here: https://github.com/ros-drivers/rosserial/issues

Comment by luxifu1989 on 2014-02-13:
The same problem that nothing happens in hydro even though I downloaded the newest rosserial_client from the github.

Comment by 4LV4R0 on 2014-02-13:
I have not reported it yet. I´m reporting when I finished a class . Thanks to both of you.

Comment by 4LV4R0 on 2014-02-14:
Reported here : https://github.com/ros-drivers/rosserial/issues/96

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

In groovy/hydro, things were updated so that A) each client has it's own make_libraries.py script (for instance rosserial_adruino is different from rosserial_embedded_linux, this allows us to set things like endianness and whether the platform supports Float64) B) all messages are generated at once for every package on your path. Therefore, you need to run:

rosrun rosserial_arduino make_libraries.py <sketckbook_output_folder>

This will generate messages for ALL installed packages. The Arduino IDE tutorial has been updated, but not the one you reference (I'll update it right now).


Originally posted by fergs with karma: 13902 on 2014-02-14

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by luxifu1989 on 2014-02-16:
Thank you for reply. All works well now.

Comment by 4LV4R0 on 2014-02-16:
I´ve tried 5 minutes ago. It perfectly worked for us. Thanks you so much

Comment by Anas Alhashimi on 2015-11-20:
I still can't find it in Fuerte!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.