Rosanswers logo

Since camera_pose_calibration was never updated, I finally got the patched version of camera_pose from Github via this:

$ git clone https://github.com/jbohren-forks/camera_pose.git

Unfortunately I'm not allowed to modify the files in ROS directories. I figured out that I would refer to the folder I put it in over the original ROS camera_pose folder by listing it first in ROS_PACKAGE_PATH but I'm still getting errors. How would I eliminate the old camera_pose folder? Using ROS Hydro right now.

Edit 1: After following the overlay instructions and using roscd to check that camera_pose is being looked at in my testspace first (it is), I'm encountering new errors.

This white text

terminate called after throwing an instance of 'pluginlib::LibraryLoadException'
what(): rospack could not find the image_transport package containing image_transport::PublisherPlugin

Followed by this red text

[kinect_1/stereo_cb_detector-2] process has died [pid 3069, exit code -6, cmd /opt/ros/fuerte/stacks/calibration/image_cb_detector/bin/image_cb_detector_action image:=image_throttle camera_info:=camera_info __name:=stereo_cb_detector __log:=/home/robot2/.ros/log/6b38aca2-7e0e-11e3-8b67-b8ca3a789964/kinect_1-stereo_cb_detector-2.log].

This error shows for all 3 Kinects.

Another white error

/home/robot2/Desktop/Testspace/src/camera_pose/camera_pose_calibration/src/camera_pose_calibration/multicam_capture_exec.py", line 43, in <module>
    from camera_pose_calibration.robot_measurement_cache import RobotMeasurementCache
ImportError: No module named camera_pose_calibration.robot_measurement_cache

Followed by red error

[capture_exec-19] process has died [pid 3315, exit code 1, cmd /home/robot2/Desktop/Testspace/src/camera_pose/camera_pose_calibration/src/camera_pose_calibration/multicam_capture_exec.py kinect_1 kinect_2 kinect_3 request_interval:=interval_filtered __name:=capture_exec __log:=/home/robot2/.ros/log/6b38aca2-7e0e-11e3-8b67-b8ca3a789964/capture_exec-19.log].
log file: /home/robot2/.ros/log/6b38aca2-7e0e-11e3-8b67-b8ca3a789964/capture_exec-19*.log

And a white message

ImportError: No module named camera_pose_calibration.msg

Then a bunch of angry red text. Any ideas? I also have included the roswtf output:

ERROR Could not contact the following nodes: * /kinect_2/stereo_cb_detector

  • /kinect_3/stereo_cb_detector * /kinect_1/stereo_cb_detector

ERROR The following nodes should be connected but aren't: * /kinect_3/stereo_cb_detector->/rosout (/rosout) * /kinect_1/stereo_cb_detector->/rosout (/rosout) * /kinect_2/stereo_cb_detector->/rosout (/rosout)

And for all three:

ERROR Errors connecting to the following services: * service [/kinect_2/stereo_cb_detector/set_logger_level] appears to be malfunctioning: Unable to communicate with service [/kinect_2/stereo_cb_detector/set_logger_level]

ERROR Errors connecting to the following services: * service [/kinect_2/stereo_cb_detector/get_loggers] appears to be malfunctioning: Unable to communicate with service [/kinect_2/stereo_cb_detector/get_loggers]

Any ideas?

Originally posted by Athoesen on ROS Answers with karma: 429 on 2014-01-13

Post score: 1


1 Answer 1


Rosanswers logo

If I understand your question, I think you should clone this fork into your workspace source folder(your_ws/src/) and source the setup file found in your_ws/devel/setup.bash. This will overlay the fork package over the original package.

Originally posted by gustavo.velascoh with karma: 756 on 2014-01-13

This answer was ACCEPTED on the original site

Post score: 1

Original comments

Comment by felix k on 2014-01-13:

Comment by Athoesen on 2014-01-15:
I found this incredibly helpful. Unfortunately now it's producing different errors. I'm not sure if they're from it, or just ones that were hidden by previous errors.

Comment by gustavo.velascoh on 2014-01-15:
Did you execute catkin_make on your workspace? it seems like can't find camera_pose_calibration message

Comment by Athoesen on 2014-01-15:
Yes, I followed the directions. It's still throwing me errors. I've tried both sourcing the workspace under my Groovy sourcing in the .bashrc file, and also just doing it from terminal window. Each time I get TONS of errors from camera_pose_calibration, moreso than without trying to overlay.

Comment by simaopp on 2017-11-10:
Have you solved the errors? I am getting the same errors


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.