Rosanswers logo


I am having a problem installing ROS Hydro on Ubuntu 12.04. The problem appears to be related to Openni/PCL binaries.

I am tyring to install ros-hydro-desktop. I have a x64 machine (might be the problem)

I used to have ROS Fuerte installed, but completely removed it. Steps taken:

sudo apt-get remove ros-fuerte-ros
sudo apt-get autoremove

I also update to the the distribution.

sudo apt-get dist-upgrade

When I try to install ROS hydro

 sudo apt-get install ros-hydro-desktop

I get the following response

The following packages have unmet dependencies:
ros-hydro-desktop : Depends: ros-hydro-viz but it is not going to be installed

Digging deeper into this leads to the following problem

ps-engine : Depends: openni-dev (>=

However, when trying to install "openni-dev", I get the following version installed:

Get:1 http://packages.ros.org/ros/ubuntu/ precise/main openni-dev amd64

They are clearly different versions of this package. I tried going to openni but this did not solve the problem.

I followed the installation instruction from the wiki (added deb http://packages.ros.org/ros/ubuntu precise main to /etc/apt/sources.list.d/ros-latest.list)

These are the threads I have been reading that are related to this problem but do not offer a direct solution




Any feedback/ideas will be greatly appreciated. I have spent several hours on this and not getting closer :S

Originally posted by pmolina on ROS Answers with karma: 108 on 2014-01-07

Post score: 3

Original comments

Comment by pmolina on 2014-01-07:
This is an actual current problem. I still do not quite understand the position of ROS support on this. Check this very interested thread this is still ongoing....



2 Answers 2


Rosanswers logo

It looks like you might have added jochen sprickerhof's ppa for PCL, which interferes with hydro.

Removing it with the following command solved the problem for me:

sudo ppa-purge ppa:v-launchpad-jochen-sprickerhof-de/pcl

Originally posted by sebsch with karma: 790 on 2014-02-20

This answer was ACCEPTED on the original site

Post score: 10

Original comments

Comment by pmolina on 2014-06-07:
Thank you very much! You are a savior! This solves most of the problems - I can now install all openni stuff without problems. I have no idea why I had that on my ppas (guess better be careful what is on my ppas from now on)

Comment by edward on 2014-07-16:
Hero of the day. Would never had figured this out myself (busy 3 hours trying to install Hydro besides Groovy)

Comment by Adnan Munawar on 2014-11-04:
Precisely, this had been a common occurance for a long time and many other workaround get you stuck somewhere in the future, like installing turtlebot etc on hydro. Thanks for the proper fix.


Rosanswers logo

I finally fixed this problem. I still do not think this is a solution, but so far it has not given me any trouble.

The problem is certainly rooted on the version of openni-dev package. I have no idea why the version currently online is 1.3.2 ...either way, this causes the package "ps-engine" to fail to install since it requires openni-dev 1.5.4 or later.

However, I installed aptitude and installed the openni-dev 1.3.2 and forced an install of an old version of ps-engine (5.2)... this however appears to play well with the PCL drivers and hence with the rest of ROS. I have however not tested this functionality, so I might run into other problems later.

Please read this thread for a full description of this: http://www.pcl-users.org/PCL-installation-unmet-dependency-problem-td4030129.html

Final commands used:

sudo aptitude install ps-engine

This will ask if it is OK to install the old version of ps-engine with the old openni-dev package (1.3) - press Y on this question. After this

 sudo apt-get install ros-hydro-desktop

Will complete without major problems.

I hope this helps other people with this problem.


Originally posted by pmolina with karma: 108 on 2014-01-08

This answer was NOT ACCEPTED on the original site

Post score: 1

Original comments

Comment by Vikas on 2014-01-22:
Just a clarification: After "sudo aptitude install ps-engine" first option will be to not install ps-engine. It should be rejected with "n" and then the next option will be to install older version of ps-engine which should be accepted.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.