Rosanswers logo

When doing the roslaunch tutorial I was suppose to use this command:

roslaunch beginner_tutorials turtlemimic.launch

I get an error which prevents me from continuing the tutorial and I've set the ROS_PACKAGE_PATH to include the catkin_ws. (also am I suppose to add the path of the catkin or the rospackage). Anyways the error I get is:

WARNING: unable to configure logging. No log files will be generated
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Invalid <param> tag: Cannot load command parameter [rosversion]: command [rosversion roslaunch] returned with code [1]. 

Param xml is <param command="rosversion roslaunch" name="rosversion"/>

Any help on this would be great as I am trying to learn ROS for the AUV we are making and I can't find anything related to this online.


EDIT: Using ROS Hydro on Ubuntu 12.04

Originally posted by capa_matrix on ROS Answers with karma: 16 on 2014-01-01

Post score: 0

Original comments

Comment by ahendrix on 2014-01-02:
Can you run rosversion roslaunch ? Is this an installation from debs or from source?

Comment by h iman on 2014-02-25:
I have the same error when following the tutorial. When I run 'rosversion roslaunch' the version is 1.9.50.


1 Answer 1


Rosanswers logo

@capa_matrix I had the same problem too and it was due to: (1) my workspace was not added to the ROS_PACKAGE_PATH or (2) I had change the variable ROS_PACKAGE_PATH to only ~/catkin_ws or elsewhere

Try this:


if you get


then launch your .launch file

$ roslaunch beginner_tutorials turtlemimic.launch

Originally posted by h iman with karma: 36 on 2014-02-26

This answer was ACCEPTED on the original site

Post score: 1

Original comments

Comment by Dirk Thomas on 2014-02-26:
You should never need to manually extend your package path for catkin packages. Just make sure to build the workspace and afterwards source the generated setup file.

Comment by h iman on 2014-02-27:
Thank you @Dirk Thomas. Does this means that I need to source the setup file in devel folder each time I need to work on a particular package?

Comment by Dirk Thomas on 2014-02-27:
Whenever you want to use stuff from a catkin workspace you have to source its setup file since it defines various variables necessary to find packages, plugins, binaries, libraries etc.

Comment by h iman on 2014-02-27:
Is there anyway to source the setup file automatically when I run roscore? Or is it not a good practice to do so?

Comment by Dirk Thomas on 2014-02-27:
If you haven't source any setup file you won't even be able to run roscore because it will not be on your path.

Comment by Dirk Thomas on 2014-02-27:
You can source whatever setup file you like in your bashrc file. It is personal preference if you would like to do so. Since I have numerous workspace I just source them manually or via an alias.

Comment by h iman on 2014-02-27:
I see. Thanks so much Dirk.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.