0
$\begingroup$

Rosanswers logo

When I use the command:

 rosdep install --from-paths src --ignore-src --rosdistro hydro -y

It reports the errors:

executing command [sudo apt-get install -y liblog4cxx10-dev]
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 liblog4cxx10-dev : Depends: libaprutil1-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
ERROR: the following rosdeps failed to install
  apt: command [sudo apt-get install -y liblog4cxx10-dev] failed

Could anyone help me? I googled around and tried, but still cannot install liblog4cxx10-dev. Here is the details:

If I type enter code heresudo apt-get install -y liblog4cxx10-dev`,

It has the error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 liblog4cxx10-dev : Depends: libaprutil1-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Originally posted by pennpanda on ROS Answers with karma: 11 on 2013-12-23

Post score: 0


Original comments

Comment by tfoote on 2013-12-25:
What OS are you running? What are your apt-sources?

Comment by pennpanda on 2013-12-26:
Hi, My OS is Ubuntu 12.04 TLS 64bit. I want to install desktop version with the command " $ rosinstall_generator desktop --rosdistro hydro --deps --wet-only > hydro-desktop-wet.rosinstall". But I mistakely typed the command for desktop_full which is "$ rosinstall_generator desktop_full --rosdistro hydro --deps --wet-only > hydro-desktop-full-wet.rosinstall". So I delete the hydro-desktop-full-wet.rosinstall file and re-run the command "$ rosinstall_generator desktop --rosdistro hydro --deps --wet-only > hydro-desktop-wet.rosinstall".

I have added the ros's source into my system with the command "sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu precise main" > /etc/apt/sources.list.d/ros-latest.list'"

Thank you so much for your reply!

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

This is an issue with your underlying ubuntu system. The two packages you are trying to install are both upstream in the Ubuntu Universe repos:

http://packages.ubuntu.com/precise/liblog4cxx10-dev and http://packages.ubuntu.com/precise/libaprutil1-dev

You should try to find the lowest level package which won't install and try it. Also aptitude will give better errors than apt-get.


Originally posted by tfoote with karma: 58457 on 2013-12-26

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by pennpanda on 2013-12-29:
@tfoote Thank you so much! I solved it and posted the solution in the following answer. :)

$\endgroup$
0
$\begingroup$

Rosanswers logo

Problem solved with the following approach:

  1. If you keep using the apt-get to install the missing package, you will find the error: libsqlite3-dev : Depends: libsqlite3-0 (= 3.7.9-2ubuntu1) but 3.7.9-2ubuntu1.1 is installed.

  2. Then you can use the "sudo aptitude install libsqlite3-0=3.7.9-2ubuntu1" to install this missing package. Make sure this package is installed. This package is the problem.

  3. install liblog4cxx10-dev using apt-get install; it should succeed.

  4. use the ros install program to install the dep. command is: rosdep install --from-paths src --ignore-src --rosdistro hydro -y


Originally posted by pennpanda with karma: 11 on 2013-12-29

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.