0
$\begingroup$

Rosanswers logo

Hi! I'm using a VM with Ubuntu 12.04, the Kinect xbox 360 (1414) and a ROS Groovy installation. I can connect the Kinect to the VM and I get the full topic list using rostopic list with both Oppenni and Freenect running (my USB ports are USB 2.0). However, no data is shown when I type rostopic hz /camera/rgb/image_raw or rostopic echo /camera/rgb/image_raw and if I try rviz or image_view I don't get any output. Any suggestions to what might be wrong? Thanks!


Originally posted by trinnan on ROS Answers with karma: 1 on 2013-12-17

Post score: 0


Original comments

Comment by Tim Sweet on 2013-12-18:
Are you trying to do this on just the virtual machine, or is your system distributed over the network using multiple machines? This usually happens when the two ros nodes (ie OpenNI and rostopic) cannot communicate with eachother, in which case you might just need to set ROS_MASTER_URI and ROS_IP

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hi,

I had exactly your problem several months ago, and posted pretty much the same question: http://answers.ros.org/question/63428/turtlebot-2-on-virtual-machine-with-no-kinect-picture/

Unfortunately, the only way I could solve the problem was to give up on the virtual machine and install a dual-boot on my laptop.


Originally posted by BlitherPants with karma: 504 on 2013-12-20

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.