0
$\begingroup$

Rosanswers logo

When trying to pair an Android device with the Rocon_app_manager as per [1], the 'Robot Remocon' Android app does find the robot when pressing 'Add a robot > Scan the local network', but when pressing 'select' it tries to connect but displays an error:

org.ros.exception.RosRuntimeException: timed out waiting for a gateway_info publication

I tried on different networks (university-wide and at home through a local router) and two different pc's and android devices. There is at least some communication as there's a different error when the rocon_app_platform hasn't been started on the pc.

I tried to look up where this error originates but I am quite hopeless. Does anyone have an idea of how to solve this?


[1] wiki.ros.org/rocon_app_manager/Tutorials/hydro/Pairing%20with%20Androids


Originally posted by The Fonz on ROS Answers with karma: 13 on 2013-12-13

Post score: 1


Original comments

Comment by Daniel Stonier on 2014-06-29:
Any chance that some of the problems here are due to the fact that you are using android devices that have multiple interfaces? You can diagnose by checking rostopic list and rosservice list to see if the connections are there. rostopic info on an android topic will show strange ip's.

Comment by Daniel Stonier on 2014-06-29:
This error is quite vague sorry....we have simplified communications hugely getting ready for indigo with better error feedback (yet to be released though).

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

I think probably your ROS_IP/ROS_HOSTNAME/ROS_MASTER_URI are not correctly set on the turtlebot for multi-device-pc communication. Some information on the roswiki and the turtlebot wiki.

The 'dumb' error message unfortunately is a late hydro regression I have yet to fix - it used to actually provide a hint to make sure you have your ROS_IP/ROS_HOSTNAME set.


Originally posted by Daniel Stonier with karma: 3170 on 2013-12-16

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by The Fonz on 2014-01-17:
You're right - setting ROS_IP and ROS_HOSTNAME in .bashrc works, per the instructions in the turtlebot wiki. Still not very stable, sometimes it connects, sometimes on retry, sometimes on app restart.

Comment by Daniel Stonier on 2014-01-19:
Still quite beta, occasionally state gets confused if something goes awry. We're working hard to upgrade/stabilise the android environment better for igloo.

$\endgroup$
0
$\begingroup$

Rosanswers logo

Hello, somehow I do face the same problems. In some networks there is not a problem at all to connect with the android app to the master, but in others I get the error mentioned above. So fare I just could connect sucessfully when creating a network with my android phone where I connected the ROS master and the tablet I'm using. In all my test scenarios the ROS master had set the ROS_IP correct. I used our university WLAN (did not work) and a dedicated WLAN network with a private network (did also not work).

Is there any special need the network has to fullfill?

Best Wishes Johannes


Originally posted by Johannes with karma: 75 on 2013-12-23

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by Daniel Stonier on 2014-01-14:
None that I can think of, but it may well be that we just haven't come across such a network. Logcats would be the next immediate step, but if they don't have enough information, it's down to debugging internals of rosjava.

Comment by Daniel Stonier on 2014-01-14:
Really need to identify what is different between the networks where you have success and where you didn't. I could perhaps reproduce the problem here then and debug.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.