Rosanswers logo

Hello everybody!

I'm trying to use the ORK on ubuntu 12.04 with ros Hydro. I installed it using sudo apt-get install ros-hydro-object-recognition-*. I did not install couchapp (sudo pip install -U couchapp), as, if I understood well, it is not necessary. Now, following this tutorial, I have a kinect connected to my computer and running:

rosrun openni_launch openni.launch

works properly, as I can see the depth image with image_view. However, when I try to use the command:

rosrun object_recognition_capture orb_template -o my_textured_plane

what happens is that the depth image that appears is all black and the ORB window all red. Moreover I noticed that if I try to run this command with the image_view running and showing the depth image, the image_view stops to be updated, i.e. the openni.launch doesn't publish anymore the /camera/depth/image topic. Also when I stop running the orb_template command, the depth image topic still isn't published.

Any help would be appreciated! Thanks!!


this is the output of the command rosrun object_recognition_capture orb_template -o my_textured_plane

Listening for key: s on imshow:save
Registration? 1
Sync? 0
1. device on bus: 2 @ 6 with serial number: A00365A03335051A  Microsoft : Xbox NUI Camera
Time diff max: 16.8667
Registered:on Supported: 1
Setting registration on
Setting sync off

Originally posted by Tirjen on ROS Answers with karma: 808 on 2013-12-12

Post score: 0


1 Answer 1


Rosanswers logo

Are you using a 32 bit Ubuntu? Then it is a known Bug. Just install 64 bit Ubuntu and move on! See https://github.com/wg-perception/capture/issues/15#issuecomment-30496760

Greets, O3

Originally posted by o3p7s5 with karma: 86 on 2013-12-15

This answer was ACCEPTED on the original site

Post score: 1

Original comments

Comment by Tirjen on 2013-12-15:
That's it! Thank you! I will try it in a few days!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.