0
$\begingroup$

Rosanswers logo

I'm trying to use the Asus Xtion Pro camera with openni on Ubuntu 12.04. It does not work. Running dmesg in the terminal gives:

[15844.380294] usb 3-9: new high-speed USB device number 13 using xhci_hcd
[15844.400319] usb 3-9: New USB device found, idVendor=1d27, idProduct=0600
[15844.400327] usb 3-9: New USB device strings: Mfr=2, Product=1, SerialNumber=0
[15844.400333] usb 3-9: Product: PrimeSense Device
[15844.400337] usb 3-9: Manufacturer: PrimeSense
[15844.401720] usb 3-9: Not enough bandwidth for new device state.
[15844.401738] usb 3-9: can't set config #1, error -28

I've tried all the USB ports on the computer. It always gives the same error.


Originally posted by atp on ROS Answers with karma: 529 on 2013-11-30

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I've solved this problem by deactivating xHCI and EHCI Hand-off in the bios of the motherboard.


Originally posted by atp with karma: 529 on 2013-12-03

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by Martin Günther on 2013-12-04:
Yup, that seems like a good solution. The Xtion and Kinect don't work on USB 3.0 (xhci) ports. If you're lucky, your PC has at least one USB 2.0 (ehci) port; otherwise, you have to disable xhci (either in the bios, or by blacklisting the kernel module).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.