0
$\begingroup$

Rosanswers logo

Hello everybody!

I was planning to test some of my packages on the ARM-based Odroid-XU (ROS hydro on Linaro 13.05), but experienced some strange behavior when trying to play back a bag file.

When I execute the command rosbag play mybag.bag, I get the following output:

[ INFO] [1385631615.554476003]: Opening mybag.bag

Waiting 0.2 seconds after advertising topics... done.

Hit space to toggle paused, or 's' to step.

The problem is that it never got to the stage that it would say:

[RUNNING]  Bag Time: 1381311745.123451   Duration: {time} / 78.856356

But as soon as I quit with ctrl+c, it will display:

[RUNNING]  Bag Time: 1381311666.267094   Duration: 0.000000 / 78.856356     
^C

I tried fiddling around with the different options and had a minor success with -i (play back all messages without waiting). With this option the bag is plays back in a couple of seconds. I think it is interesting that this works, however it does not help in my case.

I have also tried different bags, all of them have been extensively used on my workstation.

Has anyone else experienced this problem? Any clue about how to fix this?

Best

Tim


Originally posted by timster on ROS Answers with karma: 396 on 2013-11-27

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

This is due to a bug in rosbag.

It's fixed in https://github.com/ros/ros_comm/pull/311 , which hasn't been released or built for ARM yet. I recommend building ros_comm from source.

EDIT

This is fixed in the latest builds of ROS for ARM. Note that the repository URL has changed; see: http://wiki.ros.org/hydro/Installation/UbuntuARM


Originally posted by ahendrix with karma: 47576 on 2013-12-09

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.