0
$\begingroup$

Rosanswers logo

We have a PrimeSense Carmine sensor (1.09), it works before under both Groovy and Fuerte following the workaround provied by PrimeSense Carmine doesn't work, but ASUS Xtion does. But after several updates, the openni_launch in Groovy no longer works, while the Fuerte one still do. I did the following experiments to investigate the error:

== under ROS Groovy and Fuerte, original package WITHOUT Sensor-Bin-Linux-x86-v5.1.2.1 ==

Driver won't start with openni.launch, giving such error:

[ INFO] [1385557309.784984535]: No devices connected.... waiting for devices to be connected

== under ROS Groovy, after installing Sensor-Bin-Linux-x86-v5.1.2.1 ==

openni.launch will crash, giving many errors, only sensable ones are listed here:

terminate called after throwing an instance of 'openni_wrapper::OpenNIException'
  what():  unsigned int openni_wrapper::OpenNIDriver::updateDeviceList() @ /tmp/buildd/ros-groovy-openni-camera-1.8.9-0precise-20131016-0128/src/openni_driver.cpp @ 125 : enumerating image nodes failed. Reason: One or more of the following nodes could not be enumerated:

           Image: PrimeSense/SensorV2/5.1.2.1: Failed to set USB interface!

           [FATAL] [1385557181.994270107]: Service call failed!

== under ROS Fuerte, after installing Sensor-Bin-Linux-x86-v5.1.2.1, it works smoothly(like the Kinect!) ==

Since we have many other modules work only in ROS Groovy, so we have to make the camera driver working under the same distribution. We are running all these under a 32-bit ubuntu 12.04 machine.

update

I checked the ros-groovy-openni-camera package versions, the current version(20131016) does not work. And I cannot install the old version:

apt-get install ros-groovy-openni-camera=1.8.8-0precise-20130326-0820-+0000

E: Version '1.8.8-0precise-20130326-0820-+0000' for 'ros-groovy-openni-camera' was not found

1.8.8-0precise-20130326-0820-+0000
# this seems to be the start point when it failed
1.8.9-0precise-20130715-0342-+0000
1.8.9-0precise-20130722-0045-+0000
1.8.9-0precise-20130724-2247-+0000
1.8.9-0precise-20130926-0224-+0000
1.8.9-0precise-20131016-0128-+0000

Any suggestions are welcome, thanks in advance!


Originally posted by K Chen on ROS Answers with karma: 391 on 2013-11-27

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Already have an issue here, https://github.com/ros-drivers/openni_camera/issues/18


Originally posted by K Chen with karma: 391 on 2013-11-27

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by Andrew.A on 2013-11-27:
Did you try to check out the source code and compile it yourself? Try using the 1.8.8 or rollback_usb branch.

Comment by Andrew.A on 2013-11-27:
I have a solution here: http://answers.ros.org/question/70585/roslaunch-openni_launch-opennilaunch-no-devices-connected. I'm using 12.10 with groovy, but you can try and see if it works.

Comment by K Chen on 2013-12-06:
Thanks @Andrew.A ! I followed your guide to download the source and compile it on the rollback_usb branch, now it works.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.