0
$\begingroup$

Rosanswers logo

Hello guys,

This is my first post here on ros answers, and I feel very honored for being a part of this community. I've recently started working with TurtleBot on a project here at my University, which has a goal to gather a RGB-D dataset in order to build semantic maps. In a nutshell, I need to get the TurtleBot moving around the halls of a building, saving RGB and depth information while doing it. I have completed all turtlebot and rosbag tutorials, however a situation came up:

  • When the turtlebot is navigating autonomously on a known map, the topic /camera/rgb/image_color (which provides the colored image), is gone! I'm only left with the /camera/rgb/image_raw, which does not suit my needs (not because it's not colored, but because it has strange "dots" on it). I have tried to use the 3dsensors launcher (which makes the image_color topic show up) while navigating, but apparently launching it causes the navigation mode to freeze.

So, my question is: is there any way to record colored images to a bag while the TurtleBot is navigating autonomously on a known map? If there isn't, do I have good alternatives in order to achieve my goal?

Thanks in advance,

Marlon Marques


Originally posted by thesir on ROS Answers with karma: 3 on 2013-11-14

Post score: 0


Original comments

Comment by Henschel.X on 2016-04-06:
I followed the answer to copy code from amcl_demo.launch and set false to true, but when I roslaunch my new launch file, it just gives me warnning, "waiting transform from......". Have you met this situation?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

First things first, I'm guessing you are launching amcl_demo.launch for the navigation. You'll note that it too calls 3dsensors.launch, so if you try and launch 3dsensors.launch again while navigating, this is probably the reason for it freezing - you are trying to start an already started set of 3d sensor nodes which is a use case that we don't have development time to support ;)

You'll also note inside amcl_demo.launch, there are some args that get passed to 3dsensor.launch. I think the one you want is to set rgb_processing to true.

Solution might be to write your own custom launcher. Model it off that amcl_demo.launch and set the rgb_processing to true.


Originally posted by Daniel Stonier with karma: 3170 on 2013-11-24

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by thesir on 2013-11-24:
Muchas Gracias, amigo! I should have looked inside the launch file before I came in here, haha. I also set the argument depth_registration to true, because I needed it as well. Now everything's working just fine! Thank you so much!

Comment by Henschel.X on 2016-04-06:
I followed the answer to copy code from amcl_demo.launch and set false to true, but when I roslaunch my new launch file, it just gives me warnning, "waiting transform from......". Have you met this situation?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.