0
$\begingroup$

Rosanswers logo

I am writing a rqt plugin (ROS Hydro, Ubuntu 12.04.3 LTS, x86_64) at moment following the rqt tutorial: Create your new plugin.

Unfortunately, my plugin is not in the list returned by "rqt --list-plugins". rosrun also fails.

$ cd ~/rqt_ws/

$ catkin_make

$ rosrun rqt_mypkg rqt_mypkg

qt_gui_main() found no plugin matching "rqt_mypkg"


Originally posted by Gripen on ROS Answers with karma: 111 on 2013-10-15

Post score: 11


Original comments

Comment by Chief_534 on 2013-10-17:
I'm having the same issue using ROS Groovy. Everything builds and installs properly, but I can't run the plug-in. I can even open and build it without issue in QT Creator. I'm currently running off of the binary packages. Any advice?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Appears to be a problem with rqt caching the locations of plugins in its config and not updating that info. A workaround that works for me is delete that cache and restart rqt:

$ rm ~/.config/ros.org/rqt_gui.ini
$ rqt

A 2nd workaround: this appears to work using the latest rqt source (groovy-devel branch, which is also used to build the hydro packages), so this looks like a bug in the released packages as opposed to a problem with the tutorial. I added the following to my hydro workspace:

- git: {local-name: qt_gui_core, uri: '[email protected]:ros-visualization/qt_gui_core.git'}
- git: {local-name: rqt, uri: '[email protected]:ros-visualization/rqt.git'}
- git: {local-name: rqt_common_plugins, uri: '[email protected]:ros-visualization/rqt_common_plugins.git'}

and a new plugin was found and ran.


Originally posted by markpitchless with karma: 390 on 2013-10-16

This answer was ACCEPTED on the original site

Post score: 30


Original comments

Comment by Frederik on 2013-10-26:
I have the same setup as the initiator (ROS Hydro, Ubuntu 12.04.3 LTS, x86_64) and face exactly the same problem.

Also overlaying the proposed meta-packages did not solve the problem.

Comment by bit-pirate on 2013-11-04:
This might be a bug. Follow this issue for details: https://github.com/ros-visualization/rqt/issues/90 .

Comment by zsbhaha on 2014-04-19:
Thank you very much ! The problem had confused me a long time .

Comment by dennis.tryk on 2014-08-06:
I am having the same problem. When you say you've added this to your hydro workspace, how exactly is that done. I am working in ROS Groovy.

Comment by ahendrix on 2014-08-06:
If you follow the bug in question, the fix for this is to add the --force-discover option when running rqt.

Comment by Mike Zobot on 2018-04-20:
Just want to say thank you ! I even tried to reinstall ros but doesn't work. Because the config file never been removed....

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.