0
$\begingroup$

Rosanswers logo

I have been running ardrone_autonomy with an AR.Drone1.0 and it has been working great. Today I bought an AR.Drone2.0 and assumed that my code would work out of the box. Unfortunately ardrone_autonomy ardrone_driver throws this error over and over again:

One option (0) is not a valid option because its size is zero
[Navdata] Checksum failed : 1006 (distant) / 34055 (local)
Tag 12504 is an unknown navdata option tag

Is there something I need to change in the code / launch file to make it compatible with the AR.Drone2.0?

I should also mention (though I don't think it's relevant) that I modified ardrone_autonomy to make it catkin compatible.


Originally posted by ounsworth on ROS Answers with karma: 37 on 2013-10-15

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

You have to look for the drone firmware. it must be 2.3.3

look here https://github.com/AutonomyLab/ardrone_autonomy/issues/69

we are all waiting for the new sdk from parrot


Originally posted by mmyself with karma: 138 on 2013-10-16

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by ounsworth on 2013-10-29:
Worked like charm, firmware was very easy to downgrade. Thanks!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.