0
$\begingroup$

Rosanswers logo

Trying to install Hydro i get the following problems. When i try to install one by one and go deeper i find out that libpcl-1.7 has problems how can i solve this? The following packages have unmet dependencies:

 ros-hydro-desktop-full : Depends: ros-hydro-desktop but it is not going to be installed
                          Depends: ros-hydro-mobile but it is not going to be installed
                          Depends: ros-hydro-perception but it is not going to be installed
                          Depends: ros-hydro-simulators but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have fuerte working and i need it so i cant uninstall it, any ideas will be welcomed ;)
PD: Im installing hydro only to use the pcl-1.7 so if there is another way to use it and not install hydro that would work to


Originally posted by ctguell on ROS Answers with karma: 63 on 2013-10-14

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

The error suggests that you have packages being 'held' by apt. Try searching that error. I found several potential solutions


Originally posted by tfoote with karma: 58457 on 2013-10-14

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.