0
$\begingroup$

Rosanswers logo

Hi Guys,

Using Groovy's navigation stack and move_base, I am trying to send a goal/waypoint to the robot that is at least 100 meters away from the robots current position, if not more.

The local planner that I am using is: dwa_local_planner/DWAPlannerROS

The global planner that I am using is: navfn/NavfnROS

For the local and global costmap, I do not have a "static_map", so that is false, and I have turned rolling_window to true.

The problem that I have come across is dynamic reconfigure tells me the width and height of the map has a MAX of 20 meters. It does not seem like I can get around this limitation.

I am able to go to successive goals that are less than 10 meters away from the robot, and the robot does fine getting to that position. So it looks like the rolling window is working fine. But when I give a goal at a distance greater than 10 meters it gives off this warning:

"The goal sent to the navfn planner is off the global costmap. Planning will always fail to this goal."

Is there a way to increase the global costmap greater than 20x20 meters, or another parameter I can change so the global planner can just plan as the robot moves?

Thank you for any suggestions.


EDIT:

So it looks like setting the height and width to greater than 20x20 in my global_costmap yaml file WORKS. This file is called in the launch file. But if move_base crashes and than respawns it will set the height and width of the global costmap back to 20x20. This is bad as the waypoints fall off the global costmap again and the planner fails.

Is there a way to make the parameters persist after a crash and respawn of move_base?


Originally posted by Raptor on ROS Answers with karma: 377 on 2013-10-11

Post score: 1


Original comments

Comment by David Lu on 2013-10-12:
You should be able to set the parameters for the width/height in the parameter server (NOT via reconfigure) to >20.

Comment by Raptor on 2013-10-21:
It looks like this works, but if move_base crashes and respawns it looks like the height and width go back to 20x20. I assume this is because even though the parameters is set to 100x100, when I do a rosparam get on the height and width, they are still set at 20. The "Map Size" is created at start.

Comment by David Lu on 2013-10-23:
I have double checked the cause of this error. This is indeed a bug, which has been fixed in Hydro. What version are you using?

Comment by Raptor on 2013-10-23:
I was using Groovy a couple weeks ago, but since this bug, I have upgraded all my software to run with Hydro. I still have to take it outside to test, but am pretty confident it will work now. If I still have the problem, I will let you know, otherwise consider it fixed.

Comment by ctguell on 2014-03-18:
@Raptor @David Lu im having the same problem but i cant go put the goal more that 4mt away, im using gmapping with navigation in ros fuerte, any help would be really appreciated, i used this answer but it did not work http://answers.ros.org/question/9456/how-to-set-unknown-pixel-as-goal-in-move_base/

Comment by Raptor on 2014-03-20:
Hi @ctguell, the question in this thread, and in the link you posted are different problems then what you are having. Your problem probably has to do with your move_base and gmapping configurations. Please ask a new question, in a new thread and post all your YAML and ros param values/configurations

Comment by ctguell on 2014-03-27:
@Raptor thanks i solved it ;)

Comment by dalishi on 2014-06-12:
Hi Raptor just want to ask have solved the problem with the dwa local planner? Can you advise me your configure? Currently, I set the planner in the move_base but it does not work. I am not even able to get global plan with this dwa_local_planner. Thanks in advance.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Just confirming the Answer which was given in the comments.

"This is a bug, which has been fixed in Hydro."


Originally posted by Raptor with karma: 377 on 2015-01-07

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.