0
$\begingroup$

Rosanswers logo

Hi,

I am trying to reproduce the same color behaviour from the "hector_quadrotor outdoor scenario demo" youtube clip. In this clip in the top down view from rviz the hector team gets a nice color visualization of the laserscan.

What settings do you choose in rviz under the LaserScan category to achieve the same?

I tried various and I'm currently using:

  • Topic: /scan
  • Queue Size: 10
  • List item
  • Selectable: yes
  • Style: Points
  • Alpha:10
  • Decay Time: 10
  • Position Transformer: XYZ
  • Color Transformer: AxisColor Axis: Z
  • Autocompute Value Bounds: yes
  • Use Fixed Frame: yes

With this setting I get a very colorful image but to me the colors don't make sense at all. There is no consisting color change as it can be observed in the hector youtube clip. For example I get green lines after blue ones and then blue again.

I use Ubuntu 12.04 and ROS fuerte and run the outdoor_flight_gazebo.launch file from the hector_quadrotor_demo package.

Thanks a lot.


Originally posted by neptun on ROS Answers with karma: 23 on 2013-10-04

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

The culprit is the "autocompute value bounds" option. This means that for every scan the min/max values for coloration are computed in isolation, so coloring is not consistent across multiple scans. Switching off the autocompute, you can set the bounds yourself manually. It´s of course advisable that you are using some reasonable fixed frame for this to work as intended.


Originally posted by Stefan Kohlbrecher with karma: 24361 on 2013-10-04

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by neptun on 2013-10-06:
Perfect, thanks! I tried it without "autocompute value bounds" but due to wrong min/max values I never got the desired result. Now it works!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.