0
$\begingroup$

Rosanswers logo

Good evening partners I'm trying yo install the mobile on a Raspberry pi running Raspbian at step 3.1 of Groovy Installation Guide. Following the recommendation I have been given the following error :

Using initial elements from: http packages ros org/web/rosinstall/generate/raw/groovy/mobile ERROR in config: Invalid multiproject yaml format in [http //packages ros org/web/rosinstall/generate/raw/groovy/mobile]: mapping values are not allowed here in "", line 14, column 20

I have deleted dots because I can't publish links yet I can be able to continue with the installation process. Could you help me please?

Thanks


Originally posted by 4LV4R0 on ROS Answers with karma: 70 on 2013-10-02

Post score: 0


Original comments

Comment by tonybaltovski on 2013-10-03:
Which guide are you following?

Comment by 4LV4R0 on 2013-10-04:
I was following this guide http://wiki.ros.org/groovy/Installation/Raspbian

But I have also read that we have to use rosinstall_generator. http://wiki.ros.org/rosinstall_generator#Installation

I´m a little lost with this beacuse I´m a completely noob

Comment by 4LV4R0 on 2013-10-07:
At Step 5.6 I´m getting this : ERROR: your rosdep installation has not been initialized yet. Please run:

rosdep update

Altought I run the update I get always the same trying "sudo rosdep check ... "

Am I doing anything wrong ?

Thanks a lot

Comment by 4LV4R0 on 2013-10-08:
I supose that it will be related; if I ignore this part and continue I can´t build the Catkin Workspace. I get this message : catkin_make It does not exist file or directory and ./src/catkin/bin/catkin_make_isolated: command not found

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

The rosinstall generator website has been removed in favor of using the command line tool rosintall_generator

Whatever instructions you are following need to be updated.


Originally posted by tfoote with karma: 58457 on 2013-10-03

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by 4LV4R0 on 2013-10-04:
Thanks

I understand that instructions that I was following are out of date so if I follow this http://wiki.ros.org/rosinstall_generator#Installation how can I get Ros Groovy functional in my Raspberry?

Whatever I have to wait for the updating ? I really need it running it on.

Thanks you so much

Comment by tfoote on 2013-10-04:
You can figure out how to substitute the command line arguments for the web query. Also if you link to the tutorial you are following, it is much more likely to be updated.

Comment by 4LV4R0 on 2013-10-04:
Sorry but as I said before I´m a beginner with this so no, I can´t figure out how to substitue the command line arguments from this sudo wstool init -j1 src http://packages.ros.org/web/rosinstall/generate/raw/groovy/desktop to make it work with the correspondient in rosinstall_generator wiki page

Comment by 4LV4R0 on 2013-10-04:
I really appreciate your interest but with answers as " You can figure out how to substitute the command line arguments for the web query" you are not helping me at all. Sorry if my lack of knowledge has bothered you to the point of answering so. I´ll try to get it work and wait for updates.Thanks

Comment by tfoote on 2013-10-06:
I've updated the instructions as best I can w/o testing. Here's the diff: http://wiki.ros.org/groovy/Installation/Raspbian/Source?action=diff&rev1=105&rev2=106

Comment by 4LV4R0 on 2013-10-07:
Thanks you so much. This evening after work I´ll test and check it. Great job and thanks to this community for everything.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.