0
$\begingroup$

Rosanswers logo

Hello! I'm trying to walk through the latest OSX install instructions. I have gotten to this step:

rosdep install --from-paths src --ignore-src --rosdistro hydro -y

When I encountered this error:

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: rqt_top: No definition of [python-psutil] for OS [osx]

I'm on 10.8.3 and this is the first time I've tried to install ROS on this laptop. (If that matters)

Suggestions for debugging ideas would be appreciated!


Originally posted by iandanforth on ROS Answers with karma: 11 on 2013-09-17

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Update 9/23/2013) patch is accepted and the reported issue should not longer be the case.


That's because psutil is missing in OSX' rosdep key.


Here is tentative workaround before the rosdep key gets updated. Since this involves modifying protected area, do it at your own risk.

I have a patch that I haven't submitted since I haven't tested on my local Mac. If you can try (eg. by doing the following steps) that would be great.

Make a backup and modify /etc/ros/rosdep/sources.list.d/20-default.list as follows:

Current: yaml https://github.com/ros/rosdistro/raw/master/rosdep/osx-homebrew.yaml osx
New: yaml https://github.com/130s/rosdistro/raw/master/rosdep/osx-homebrew.yaml osx

then run (adjust ROS distro accordingly):

$ rosdep update
$ rosdep install --from-paths src --ignore-src --rosdistro hydro -y

which should install psutil via pip.

Be sure to roll back the same file once you've done above.


Originally posted by 130s with karma: 10937 on 2013-09-18

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by JamesLloyd on 2013-09-20:
I ran into the same problem - I tried your suggestion but after trying

rosdep install rqt_top

I get the following error

rosdep install rqt_top

ERROR: Rosdep cannot find all required resources to answer your query Missing resource rqt_top

Comment by meatspace_explorer on 2013-09-21:
I'm getting the same error on 10.8.5

Comment by manichour on 2013-09-22:
10.7.x Same error with workaround.

Comment by 130s on 2013-09-22:
Sorry, there was a couple of problems with my initial description. I've corrected my post. This worked fine for me so that I've submitted a patch to include psutil into the official rosdep key https://github.com/ros/rosdistro/pull/2187

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.