0
$\begingroup$

Rosanswers logo

Hello. I am new to ROS Running Groovy on 12.04 LTS.

i am trying to add the Rosserial for the Communication of Arduino with ROS. every thing goes fine i follow this tutorial wiki.ros.org/rosserial_arduino/Tutorials/Arduino%20IDE%20Setup.

1.i installed Arduino IDE

2.i run all these commands successfully

cd catkin_workspace/src

git clone //github.com/ros-drivers/rosserial.git

cd catkin_workspace

catkin_make

catkin_make install

source catkin_workspace/install/setup.bash

Al last when i run this Command after going into the libraries folder of sketchbook.

rosrun rosserial_arduino make_libraries.py

i get this Message]

[rospack] Error: stack/package rosserial_arduino not found


Originally posted by Neo on ROS Answers with karma: 23 on 2013-09-15

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

You forgot the the dot on the last command rosrun rosserial_arduino make_libraries.py . Try that. Also, your source should be source PATH_TO/catkin_workspace/install/setup.bash if in your home directory, source ~/catkin_workspace/install/setup.bash. Can you roscd into rosserial_arduino?


Originally posted by tonybaltovski with karma: 2549 on 2013-09-15

This answer was ACCEPTED on the original site

Post score: 3


Original comments

Comment by Neo on 2013-09-24:
thnaks i am now able to compile code with ros.h in arduino IDE

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.