0
$\begingroup$

Rosanswers logo

I'm trying to install the hydro turtlebot simulator on Ubuntu 12.04 (32 bit) but the dependencies for openni seem a bit wacky. I've installed and uninstalled a few times now and nothing seems to work. It seems to boil down to ros-hydro-openni-launch refuses to install because it doesn't want to install ros-hydro-openni-camera even if ros-hydro-openni-camera is already installed.

...
The following packages have unmet dependencies:
 ros-hydro-turtlebot-bringup : Depends: ros-hydro-openni-launch but it is not going to be installed
...
 ros-hydro-openni-launch : Depends: ros-hydro-openni-camera but it is not going to be installed
...
ros-hydro-openni-camera is already the newest version.

If I have ros-hydro-openni-camera installed, and then do an "apt-get install ros-hydro-desktop-full", it removes ros-hydro-openni-camera, e.g.

Removing ros-hydro-openni-camera ...
Removing libopenni-dev ...
Removing libopenni-sensor-primesense-dev ...
Removing libopenni-sensor-primesense0 ...
Removing openni-utils ...
Removing libopenni0 ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for man-db ...
Selecting previously unselected package openni-dev.

...and I'm back at square one.

I'm guessing there's a conflict between openni-dev and libopenni-dev Any suggestions as to how to get things installed properly?

Thanks, -Mark


Originally posted by mallanmba on ROS Answers with karma: 46 on 2013-09-04

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Thanks, all looks good now. For those who were experiencing this problem, do the following:

sudo apt-get update
sudo apt-get dist-upgrade

...then install your ros debs


Originally posted by mallanmba with karma: 46 on 2013-09-05

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by tfoote on 2013-09-05:
Please accept the answer so people know your problem is solved.

Comment by pmolina on 2014-01-30:
this did not really worked for me. Please check my problem http://answers.ros.org/question/115546/cannot-install-ros-hydro-on-ubuntu-1204/

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.