0
$\begingroup$

Rosanswers logo

Hi all, I am able to run the freenect_stack on my x86 13.04 Hydro without any problems. However, I dont get any data when running on my beaglebone black 13.04 Hydro. Following is the output:

Number devices connected: 1
1. device on bus 000:00 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'A00363A02841103A'
Searching for device with index = 1
Starting a 3s RGB and Depth stream flush.
Opened 'Xbox NUI Camera' on bus 0:0 with serial number 'A00363A02841103A'
rgb_frame_id = '/camera_rgb_optical_frame' 
depth_frame_id = '/camera_depth_optical_frame' 
Camera calibration file /home/hope/.ros/camera_info/rgb_A00363A02841103A.yaml not found.
Using default parameters for RGB camera calibration.
Camera calibration file /home/hope/.ros/camera_info/depth_A00363A02841103A.yaml not found.
Using default parameters for IR camera calibration.
Stopping device RGB and Depth stream flush.
Device timed out. Flushing device.
Starting a 3s RGB and Depth stream flush.
Stopping device RGB and Depth stream flush.
Device timed out. Flushing device.

...and this repeats

I installed the stack using sudo apt-get install ros-hydro-freenect-stack.

Any suggestions welcome.


Originally posted by aswin on ROS Answers with karma: 528 on 2013-08-25

Post score: 0


Original comments

Comment by balakumar-s on 2013-09-16:
Hey there, I too am working on getting kinect working on beaglebone black. I just installed ros hydro and freenect stack but my kinect is not connecting when the freenect.launch is run.With lsusb i can see that all the three(cam,motor,audio) are visible.Could you help me out?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I played around with this a bit, both with a Kinect and with an Asus Xtion Pro Live, and I wasn't able to get either to work.

The Kinect appeared to have problems enumerating properly on the USB bus, and tended to cause the kernel on my Beaglebone Black to crash or lock up.

The Asus seemed to enumerate OK, but isn't supported by libfreenect, and I didn't have time to try a modified driver with it.

EDIT:

I've since gotten the Kinect to work with the freenect drivers on one of my other ARM boards, and I've heard other users have had good luck using the OpenNI2 drivers with the Asus Xtion.


Originally posted by ahendrix with karma: 47576 on 2013-09-17

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by DrBot on 2014-10-31:
I recently tried openni and freenect without success on a Radxa Rock board. though lsusb sees the Kinect, no data is getting published. The openni roslaunch gives a USB device not supported! message. I am thinking this a Radxa kernel module issue.

Comment by ROS_Portland_State_University_Robot on 2014-12-14:
ROS's libfreenect drivers do NOT work: they are defective and crash the Kinect. Your error report (output) is exactly what you get with those defective "drivers". The only always working drivers are Avin2

Comment by ahendrix on 2014-12-14:
I've had no trouble with the libfreenect drivers, and no trouble with the USB ports on any of my many ASUS boards. Please try to stay on-topic and be constructive with your criticism.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.