0
$\begingroup$

Rosanswers logo

Hey, I'm publishing odometry at 100 Hz and /robot_pose_ekf/odom only publishes a filtered value for roughly 1 in every four messages I give it.

running: rosservice call /robot_pose_ekf/get_status

gives the following output:

status: Input:

  • Odometry sensor

    • is active

    • received 5965 messages

    • listens to topic /odom

  • IMU sensor

    • is NOT active

    • received 0 messages

    • listens to topic

  • Visual Odometry sensor

    • is NOT active

    • received 0 messages

    • listens to topic

Output:

  • Robot pose ekf filter

    • is active

    • sent 1751 messages

    • pulishes on topics /robot_pose_ekf/odom and /tf

So it appears that it's receiving my messages successfully. Should I expect 1:1 output? I set the freq to 100 in the ekf .launch file.

I'd be happy to publish a bag file of my odometry if that helps.

Still running fuerte...

Any thoughts would be appreciated,

Cheers,

Willy


Originally posted by uuilly on ROS Answers with karma: 13 on 2013-08-22

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Actual answer:

robot_pose_ekf has a 'freq' parameter you can set:

http://www.ros.org/wiki/robot_pose_ekf#Configuration

http://www.ros.org/wiki/Parameter%20Server#Private_Parameters


Sidenote:

Do you have an IMU on your robot? Otherwise, robot_pose_ekf won't accomplish anything for you with just one odometry source.

If you need a base_footprint tf frame, use static tf publisher from /base_link: http://www.ros.org/wiki/tf#static_transform_publisher


Originally posted by Chad Rockey with karma: 4541 on 2013-08-22

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by uuilly on 2013-08-23:
Thanks Chad, Like I said, I set the freq to 100 in the .launch file. As for other sensors, we're going to add visual odometry but I wanted to make sure everything worked first. A Kalman filter should help just the encoder b/c it uses its previous estimate to influence the current estimate.

I definitely do not have a base footprint frame. Our system doesn't need one. But I can add one if it makes ekf happier.

Would any of these things prevent a 1:1 input to output ratio?

Comment by uuilly on 2013-08-23:
So I lowered the frequency that I published encoder ticks. Looks like ekf maxes out at about 20 Hz on my hardware.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.