0
$\begingroup$

Rosanswers logo

Hello,

I am currently trying to display the output of multiple cameras (Logitech c930e) using uvc_camera nodes in HD (1920 x 1080). For each camera, there is a dedicated monitor. All the monitors are mounted on same pc with graphic cards. My question is:

When I run the cameras separately using "guvcview" command, I can display the streaming of two cameras simultaneously on two monitors. But as I switch to HD mode at 30fps one of the camera stops displaying. However if I run the same configuration with 5fps, it works.

In order to use it under ROS framework, when I run two separate nodelets "roslaunch camera_nodelet.lauch" at HD 1920 x 1080, I get the following error for the second camera only:

[ERROR] [1376479436.485809503]: Failed to load nodelet [/uvc_camera] of type [uvc_camera/CameraNodelet]: unable to start capture [FATAL] [1376479436.486049480]: Service call failed! [uvc_camera-2] process has died [pid 27429, exit code 255, cmd /opt/ros/groovy/lib/nodelet/nodelet load uvc_camera/CameraNodelet /camera_process __name:=uvc_camera __log:=/home/spacebot/.ros/log/612e5f9a-04c9-11e3-871b-00248c04ba14/uvc_camera-2.log]. log file: /home/spacebot/.ros/log/612e5f9a-04c9-11e3-871b-00248c04ba14/uvc_camera-2*.log

The camera_nodelet.launch file for the second camera contains:

<param name="width" type="int" value="1920" />
<param name="height" type="int" value="1080" />
<param name="fps" type="int" value="5" />
<param name="frame" type="string" value="wide_stereo" />
<param name="device" type="string" value="/dev/video1" />
<remap from="/image_raw" to="/image_raw_02"/>

Could someone please suggest or comment that what exactly is happening?

Thank you!

PS: setting parameters from command line to change image resolution haven't been helpful.


Originally posted by zahid on ROS Answers with karma: 81 on 2013-08-14

Post score: 0


Original comments

Comment by Eric Perko on 2013-09-08:
Are both of your cameras connected to the same USB bus/controller? Can you try hooking them to USB ports that are on separate USB controllers?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Thank you Eric, I just found that it was the issue of using same USB bus. By moving one camera to other USB bus solved the issue of the HD video streaming. I guess "guvcview" was inherently adjusting the frame rate and the resolution whereas running "rosrun uvc_camera camera_node" command simply started both cameras with HD and due to USB limits, one of the camera output crashed.


Originally posted by zahid with karma: 81 on 2013-09-16

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.