0
$\begingroup$

Rosanswers logo

Hey,

So this is what I am trying to attempt right now:

I have a urdf of a robotic arm from here. I save that particular urdf in the urdf_tutorial folder based on this.

The issue is that the urdf is dependent on more files which are in the meshes folder of jaco_model (first link). In order to be able to access that folder, I cloned that package and modified the urdf so that the links in that file now point towards the corresponding folder. Unfortunately that didn't work. Can anyone let me know what's the correct procedure of doing this?

I keep getting the following error -

[ERROR] [1374693456.287422760]: Could not load resource [/home/viki/jaco_model/meshes/jaco_link_1.dae]: Unable to open file "/home/viki/jaco_model/meshes/jaco_link_1.dae". [ERROR] [1374693456.292026628]: Could not load model '/home/viki/jaco_model/meshes/jaco_link_1.dae' for link 'jaco_link_1': OGRE EXCEPTION(6:FileNotFoundException): Cannot locate resource /home/viki/jaco_model/meshes/jaco_link_1.dae in resource group Autodetect or any other group. in ResourceGroupManager::openResource at /build/buildd/ogre-1.7.4/OgreMain/src/OgreResourceGroupManager.cpp (line 753)

For more details, I am just trying to run that particular model (based on the urdf) in RVIZ so that I can modify the file and notice the changes.


Originally posted by nemesis on ROS Answers with karma: 237 on 2013-07-24

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

First thing: If it cannot find the printed file, either the software is mad or that file just isn't there. Copy that full path from the output and run ls -l <path> to check the latter.

Second thing: Originally those mesh includes are package://package_name/sub/dirs/file links, they only work if that package package_name is in your ROS_PACKAGE_PATH so ROS can find it. Which can be tested with rospack find. Your home directory probably/hopefully isn't in that path. [Equivalent: $(find package_name)/sub/dirs/file]

But an absolute ordinary linux path should work, if that file is there.


Originally posted by felix k with karma: 1650 on 2013-07-24

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by nemesis on 2013-07-26:
Thank you for your reply @felix k. It was an issue with the package(which contains the necessary files to be linked with the urdf) not being "installed" properly. There was some issue with rosdep that led to rosmake failing. I fixed that and used the "package://" format and it does open it properly now. Thank you once again though!

Comment by flabrosse on 2017-10-27:
Sorry to resurrect that, but I have the same problem and have not yet found a solution. My xacro file has and gazebo displays it correctly. However, rviz complains that it cannot find it with:

Comment by flabrosse on 2017-10-27:
"Cannot locate resource /home/ffl/catkin_ws/src/idris_sim/description/meshes/hokuyo.dae in resource group Autodetect or any other group", which is the correct path.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.