0
$\begingroup$

Rosanswers logo

now i use turtlebot(create). but kinect don't get power from Irobot create base. usb version is 2.0, and ubuntu 12.04 , ROS fuerte. Kinect is a red status light. is this problem openni problem?? if It is, please let me know what to do

If I operate openni.launch, the result is "[ INFO] [1375071903.030941613]: No devices connected.... waiting for devices to be connected"

and dashboard's result is

Node: /openni_driver Time: 1375071912.050908274 Severity: Info Location: /tmp/buildd/ros-fuerte-openni-camera-1.8.6/debian/ros-fuerte-openni-camera/opt/ros/fuerte/stacks/openni_camera/src/nodelets/driver.cpp:DriverNodelet::setupDevice:218 Published Topics: /rosout

No devices connected.... waiting for devices to be connected

what is the problem?? if you know that, please let me know.

thank you ^^


Originally posted by FourTrees on ROS Answers with karma: 27 on 2013-07-22

Post score: 0


Original comments

Comment by lifelonglearner on 2013-07-25:
I am having problem while connecting the kinect power using DB25 connector of Irobot create base. The connector circuit is designed by clearpath robotics to provide 12V DC power to kinect by taking power from pin 10 and 14 of DB25 connector of irobot create base.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I am facing the same problem that kinect not getting power from Irobot create base.... However I am very much sure that it is not an openni problem.

I read to a tutorial by Prof. Jason O'Kane he says that : For the Kinect sensor to operate correctly, it must draw power from the Create’s battery. (The 5V available from the USB connection to the netbook is not sufficient; the Kinect needs at least 8V. Note that seeing blinking lights in the Kinect is, in my experience, not enough to know for sure that the Kinect is receiving the power it needs.) Your Turtlebot has a cable connecting the Kinect to the Create for this purpose, but by default that power supply is disabled. To enable it .........

**rosrun create_node kinect_breaker_enabler.py**

I tried it but this was not working. The create base is connected to ttyACM0 port as the serial to USB connector definition. Then I checked the power supply of pin 10-11-12 of DB25 connector and found that the above command working well and I robot create giving power supply of 14V DC. So it is problem of 12V DC regulator circuit board. Which I will replace soon.


Originally posted by lifelonglearner with karma: 205 on 2013-07-28

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by lifelonglearner on 2013-07-28:
If you get to resolve the problem then please do let me too by posting the solution. Thanking you.

Comment by FourTrees on 2013-07-28:
sure, I operated 'rosrun create_node kinect_breaker_enabler.py'. but I don't solve it.
if I know that, I will notice you

Comment by FourTrees on 2013-07-29:
I sended mail about my question.

Comment by lifelonglearner on 2013-07-29:
to whom you sent the e-mail?

Comment by FourTrees on 2013-07-29:
turtlebot company -> iheartenginerring

I attached contents below

Comment by FourTrees on 2013-07-30:
I found this solution. My power cable(from create base to kinect) is wrong. +12v cable and ground cable connected incorrectly. Could you look at this part again????

Comment by lifelonglearner on 2013-07-30:
is it working now? Please e-mail me the detail about the connector n circuit you are using and steps to run. mailID- [email protected]

Comment by FourTrees on 2013-08-02:
I sended e-mail to you ^^

Comment by lifelonglearner on 2013-08-02:
When you sent, its not yet received.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.