0
$\begingroup$

Rosanswers logo

Hello all,

I want to connect my arduino to ROS and I follow the instructions on this page: http://www.ros.org/wiki/rosserial_arduino/Tutorials/Hello%20World and I have an error messages when I run this command

rosrun rosserial_python serial_node.py /dev/ttyACM0

I got these messages:

[INFO] [WallTime: 1374289833.138161] ROS Serial Python Node
[INFO] [WallTime: 1374289833.138698] Connecting to /dev/ttyACM0 at 57600 baud
[ERROR] [WallTime: 1374289850.253387] Lost sync with device, restarting...
[INFO] [WallTime: 1374289850.582506] Failed Packet Flags 
[ERROR] [WallTime: 1374289865.264259] Lost sync with device, restarting...
[INFO] [WallTime: 1374289865.567682] Failed Packet Flags 
[ERROR] [WallTime: 1374289880.273930] Lost sync with device, restarting...
[INFO] [WallTime: 1374289880.546574] Failed Packet Flags 
[ERROR] [WallTime: 1374289895.278249] Lost sync with device, restarting...
[INFO] [WallTime: 1374289895.529322] Failed Packet Flags 
[ERROR] [WallTime: 1374289910.280912] Lost sync with device, restarting...
[INFO] [WallTime: 1374289910.512166] Failed Packet Flags 

Originally posted by ahmed.shamroukh on ROS Answers with karma: 1 on 2013-07-19

Post score: 1


Original comments

Comment by asriraman93 on 2013-07-20:
I'm having the same problem - haven't been able to find a solution for a while

Comment by Loan on 2014-01-04:
You need to source the setup.bash in the ros workspace where you installed rosserrial package (I installed rosserial from source in my own workspace, as explained here).

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

I've had a problem with this and just got it to work using this post: http://answers.ros.org/question/12644/rosserial-uno-lost-sync/


Originally posted by asriraman93 with karma: 75 on 2013-07-20

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$
0
$\begingroup$

Rosanswers logo

Wow I found another solution, the one provided did not work for me! After setting thins up on three different pieces of hardware i finally found out it was a file that needed copied from src to main ros location here is the command i used please replace the username with yours. Also you must complete the groovy rosserial setup!

sudo cp -i /home//catkin_ws/src/rosserial/rosserial_python/src/rosserial_python/SerialClient.py /opt/ros/groovy/lib/python2.7/dist-packages/rosserial_python/

goodluck so for this is not working great but it works yeah... no more


Originally posted by chocjulio33 with karma: 26 on 2013-12-07

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.