0
$\begingroup$

Rosanswers logo

I am have installed ros groovy on a raspberry pi running Raspbian. I am currently trying to install rosaria following the instructions online: ros.org/wiki/ROSARIA/Tutorials/How%20to%20use%20ROSARIA

The installation fails at: rosdep install ROSARIA I get the error: ROSARIA: No definition of [dynamic_reconfigure] for OS [debian]

It turns out that I don't appear to have the debian definitions for anything, as this shows:

rosdep resolve std_msgs

ERROR: No definition of [std_msgs] for OS [debian]

No definition of [std_msgs] for OS [debian] rosdep key : std_msgs OS name : debian OS version : Data: _is_ros: true osx: homebrew: packages: - ros/groovy/std_msgs ubuntu: oneiric: apt: packages: - ros-groovy-std-msgs precise: apt: packages: - ros-groovy-std-msgs quantal: apt: packages: - ros-groovy-std-msgs

I get this same error again. Does anyone know to I get the debian definition for these rosdep keys?

I have tried doing 'rosdep init' and 'rosdep update' many times, and have done a 'sudo apt-get update' too, nothing seems to help.

Any help will be greatly appreciated, thanks.

EDIT:

Thanks po1, I manually typed in the changes in the /usr/local/lib/python2.7/dist-packages/rosdep-0.10.20-py2.7.egg/rosdep2/gbpdistro_support.py file and recompiled it to generate a new pyc file however I still get the same error when try to rosdep resolve a package, ie:

rosdep resolve geometry

ERROR: No definition of [geometry] for OS [debian]

No definition of [geometry] for OS [debian] rosdep key : geometry OS name : debian OS version : Data: _is_ros: true osx: homebrew: packages: - ros/groovy/geometry ubuntu: oneiric: apt: packages: - ros-groovy-geometry precise: apt: packages: - ros-groovy-geometry quantal: apt: packages: - ros-groovy-geometry

I've checked the file and I've not made any mistakes in the editing. Do I need to do anything else to make the changes take effect?

Many thanks.

EDIT2: Thanks po1! That solves my problem. Many thanks for your help.


Originally posted by wombat_sdu on ROS Answers with karma: 31 on 2013-07-07

Post score: 3


Original comments

Comment by po1 on 2013-07-10:
The pull request actually does not solve the problem, I just realized that. I will look into it and push something more likely to solve your problem.

Comment by po1 on 2013-07-10:
There you go: https://github.com/ros-infrastructure/rosdep/pull/262

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

This is a known limitation of rosdep. At the moment, most external dependencies resolve fine, but the ros packages do not.

A pull request has just been submitted to that effect, you can see it (and try it) here: https://github.com/ros-infrastructure/rosdep/pull/261, if you just need an ad-hoc solution I would suggest you apply the patch referenced in that pull request.

EDIT: The pull request did not solve the problem. This one, however, has been tested on a Raspbian environment. You will need to run rosdep update after updating the rosdep source.

Hope this helps.


Originally posted by po1 with karma: 411 on 2013-07-08

This answer was ACCEPTED on the original site

Post score: 4

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.