0
$\begingroup$

Rosanswers logo

I'm absolute beginner in Ubuntu and ROS. I'm using 12.04 LTS (virtualbox in windows 7) and groovy. I'm using catkin to build my workspace. This is what I did

1- I did create workspace for catkin.

2- I did create "catkin Package".

3- I did build and use catkin package in the workspace.

4- Now I want to use the example WritingPublisherSubscriber(c++)

I'm getting the following error

CMake Error at /opt/ros/groovy/share/genmsg/cmake/genmsg-extras.cmake:64 (message): add_message_files() directory not found:
/home/croco/catkin_ws/src/beginner_tutorials/msg Call Stack (most recent call first):
beginner_tutorials/CMakeLists.txt:8 (add_message_files)

-- Configuring incomplete, errors occurred! Invoking "cmake" failed

I'm sorry I can't post links; however, I'm following the tutorials literally.


Originally posted by CroCo on ROS Answers with karma: 155 on 2013-07-01

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

The tutorial seems to need an update. Please try commenting out the following three lines in your CMakeLists.txt:

# add_message_files(FILES Num.msg)
# add_service_files(FILES AddTwoInts.srv)
# generate_messages(DEPENDENCIES std_msgs)

Those are not necessary since this tutorial does not create any custom messages or services.


Originally posted by Dirk Thomas with karma: 16276 on 2013-07-01

This answer was ACCEPTED on the original site

Post score: 6


Original comments

Comment by CroCo on 2013-07-01:
@Dirk Thomas, Thank you so much. It worked.

Comment by Cássio on 2013-07-24:
Thank you, It worked.

Comment by sina.cb on 2014-02-13:
Thanks a lot! I was searching for this problem for about 2 hours. You saved my day! :)

Comment by jason on 2017-02-14:
thank you!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.