Rosanswers logo

For the last couple of days I've been trying to run the preinstalled rviz virtualization demo from my workstation rather than the Turtlebot 2 Asus Laptop and have been unable to successfully load rviz on my workstation. When loading rviz on my workstation I receive the following error in the output:

justyn@justyn-M17xR3:~$ roslaunch turtlebot_rviz_launchers view_robot.launch ... logging to /home/justyn/.ros/log/f1d3b6d8-df6e-11e2-a8cb-446d57eca273/roslaunch-justyn-M17xR3-13144.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is

I am using a Turtlebot 2 with a Kobuki base and Kinect sensor. I have installed the full desktop installation of Groovy in Ubuntu and I am able to get a result from "rostopic list" so my connection to the Turtlebot from my workstation is working. Can anyone point me to the fix for this?

Thanks in advance!

EDIT: My apologies for the many postings, the Ask Your Question page kept giving me a 504 Gateway Timeout that did not confirm my question had been submitted. Once again sorry!

Originally posted by JHarriman on ROS Answers with karma: 5 on 2013-06-28

Post score: 0

Original comments

Comment by JHarriman on 2013-07-15:
I still have the problem on the workstation I was using, I've since switched to a different workstation (physically different) with the same install and it worked.

Comment by kevinma on 2013-08-04:
Hi, I also encountered the same problem. Since I bought a complete set of turtlebot, which means it comes with a pre-installed ROS on turtlebot netbook (Asus), I found that I could load rviz with a correct turtlebot model on the netbook, but on the workstation I got the error message and could only see the model of Kinect. Therefore, I tried to find the difference. Here is what I found:

  1. in /opt/ros/groovy/stacks/kobuki_description/meshes: turtlebot netbook: there are base.dae and wheel.dae workstation: there are main_body.dae and wheel.dae

  2. If I copied base.dae to the directory on turtlebot netbook, there would be no error message and the kobuki base model showed, but in a very small scale. I guess the setups in base.dae and in main_body.dae are quite different.

Is this because of two different versions of view_model.launch mixing up? Is it a bug or I missed something in workstation installation? I would appreciate it if anyone provides any suggestions.


1 Answer 1


Rosanswers logo

Sounds like you have different versions of the debs on both turtlebot and workstation. Make sure you have the same versions.

There was also a change in the way rviz handles the meshes midway through groovy that wasn't ideal - introduced a breaking change in the way it handled scaling of the meshes. We updated the kobuki meshes to be compatible and I suspect that's where you're seeing the differences here.

Anyway, update and let us know how you fare.

Originally posted by Daniel Stonier with karma: 3170 on 2013-08-06

This answer was ACCEPTED on the original site

Post score: 3

Original comments

Comment by kevinma on 2013-08-07:
Thank you, Daniel. Yes. It turns out that the pre-installed versions of the ROS debs on the Asus netbook coming from Yujin Robot are old, which I got in July, and the versions I installed on my workstation are new. After I installed turtlebot debs again on the turtlebot netbook, it works fine now. By the way, I have hydro + raring on the workstation and groovy + precise on the turtlebot. When I load rviz on the workstation, some error messages show like: Skipping XML Document "/opt/ros/hydro/share/rviz_python_tutorial/plugin_description.xml" which had no Root Element. This likely means the XML is malformed or missing. However, it doesn't seem to affect the rviz window display and performance.

Comment by Stonier@Yujin Robot on 2013-08-07:
Probably want to avoid mixing groovy and hydro. When turtlebot hydro is ready (very close), it's probably a good idea to upgrade that one.

Comment by JHarriman on 2013-08-16:
As kevinma said, I had the same issue with pre-installed debs on the Asus netbook. I have since updated and everything works fine.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.