1
$\begingroup$

Help! I have recently installed leJOS NXJ on to my NXT brick, and soon after my batteries died. I inserted new ones, and now I cant start my brick up. When I press the startup button(orange) it makes a clicking sound and when I let go it stops. I have tried reflashing the brick with both leJOS NXJ and the NXT software and both programs say something along the lines of "unable to locate brick." Any suggetions?

$\endgroup$
  • $\begingroup$ Possible suggestion: do a hard reset (using the reset button in the Technic pin hole on the bottom of the unit), then attempt to re-upload firmware from the NXT software. $\endgroup$ – apnorton Dec 26 '14 at 20:55
1
$\begingroup$

The clicking indicates the brick is waiting for firmware download.

Double check device manager and it should also be listed there as waiting firmware.

Use either the LEGO software or another utility (eg RobotC, LeJOS) to download the firmware of your choice.

Big if -> If the device does not show up as Nxt Waiting firmware in device manager, there may be some conflict with USB drivers often installed with Arduino. It is a mess at the moment and there are no simple solutions. Keep Uninstalling (Arduino first), rebooting, re-installing (phantom drivers) until the NXT shows up as waiting firmware.

$\endgroup$
  • $\begingroup$ I blogged about the driver conflict. There are some screenshots there that might help; spiked3.com/?p=2911 $\endgroup$ – Spiked3 Jan 6 '15 at 2:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.