0
$\begingroup$

Rosanswers logo

When I try to rosmake pcl17 or pcl17_ros i get the following error:

/usr/bin/ld: cannot find -lsensor_msgs

I have the sensor_msgs package. Does anyone have any ideas as to why this would happen?


Originally posted by mdedonato on ROS Answers with karma: 61 on 2013-06-14

Post score: 0


Original comments

Comment by MichaelKorn on 2013-06-17:
We need more information. Can you describe what you did step by step? Do you use fuerte?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Not knowing what version of ROS you are using or seeing the full error message, this problem might already be solved here in this answer: How do I use pcl 1.7 with groovy?.


Originally posted by Kevin with karma: 2962 on 2013-06-14

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by Artem on 2013-06-15:
I've just compiled this one git clone https://github.com/ros-perception/perception_pcl.git -b groovy-unstable-devel. You have to change pcl-1.6 to pcl-1.7 in .//pcl/doc/tutorials/content/walkthrough.rst to successfully build other packages that depend on pcl.

Comment by MichaelKorn on 2013-06-16:
Do you have installed sensor_msgs? On Ubuntu you can do this with "apt-get install ros-groovy-common-msgs".

Comment by Artem on 2013-06-17:
BTW after I compiled PCL, rosbuild cannot compile costmap2d anymore, it cannot find pcl.

Comment by MichaelKorn on 2013-06-17:
@Art: you should use catkin

Comment by Artem on 2013-06-17:
I do use catkin to build catkin packages including pcl. However, rosbuild packages also uses catkin packages. I don't know why when I build pcl-1.7, costmap2d does not find it. I don't have the log now, I rolled back to pcl-1.6 now. Actually, let me try to build pcl-1.7 in overlay workspace.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.