0
$\begingroup$

Rosanswers logo

Hi!

I have found a bunch of questions about the same issue, but I don't think my problem is the same.

So basically, I am super new to ROS and was going through tutorial page ros.org/wiki/ROS/Tutorials/CreatingPackage

I created a package using: ~/catkin_ws/src$ catkin_create_pkg beginner_tutorials std_msgs rospy roscpp

It gave me next lines:

Created file beginner_tutorials/package.xml Created file beginner_tutorials/CMakeLists.txt Created folder beginner_tutorials/include Created folder beginner_tutorials/src Successfully created files in /home/natalia/catkin_ws/src/beginner_tutorials. Please adjust the values in package.xml.

Then I try command like roscd beginner_tutorials and it says: roscd: No such package/stack 'beginner_tutorials'

I have checked my path with echo $ROS_PACKAGE_PATH and got: /home/natalia/catkin_ws/src:/opt/ros/groovy/share:/opt/ros/groovy/stacks

and beginner_tutorials folder is in src, so it seems that path is already correct.

Do you have any suggestions what might be wrong?


So after trying rospack profile --length=200 I got:

0.005637 /opt/ros/groovy/stacks

0.001263 /home/natalia/catkin_ws/src

0.001116 /opt/ros/groovy/stacks/navigation

0.000486 /opt/ros/groovy/stacks/simulator_gazebo

0.000481 /opt/ros/groovy/stacks/navigation_tutorials

0.000405 /opt/ros/groovy/stacks/visualization_tutorials

0.000317 /opt/ros/groovy/stacks/common_tutorials

0.000285 /opt/ros/groovy/stacks/executive_smach

0.000198 /opt/ros/groovy/stacks/physics_ode

0.000185 /opt/ros/groovy/stacks/geometry_tutorials

0.000167 /opt/ros/groovy/stacks/robot_model_tutorials

0.000109 /opt/ros/groovy/stacks/slam_gmapping

0.000107 /opt/ros/groovy/stacks/robot_model_visualization

0.000092 /opt/ros/groovy/stacks/documentation

0.000036 * /opt/ros/groovy/stacks/laser_pipeline

0.000034 * /opt/ros/groovy/stacks/common

So I think that there is nothing wrong with path? But I still cannot use roscd or rospack etc. to packages I create. However, it works fine for roscpp, for example.


Originally posted by Natti on ROS Answers with karma: 130 on 2013-06-12

Post score: 11

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Maybe it's just a missing catkin_make and source devel/setup.bash, although given the ROS_PACKAGE_PATH it should work.

You could try something like rospack profile --length=200 to see what it searches.


Originally posted by dornhege with karma: 31395 on 2013-06-13

This answer was ACCEPTED on the original site

Post score: 21


Original comments

Comment by Natti on 2013-06-13:
Ah, tried catkin_make and source devel/setup.bash and now it works!! Thank you ^__^

Comment by tfoote on 2013-06-13:
@Natti please accept this answer using the checkmark at the left.

Comment by Andres on 2013-07-27:
I had the same problem. For step by step beginners: $ cd ~/catkin_ws/ $ catkin_make this will traverse the packages and add a subdirectory. followed by $ source devel/setup.bash

Comment by Allison on 2015-03-06:
You can also create an alias to run all of the commands:

alias cat_make='cd ~/catkin_ws/ && catkin_make && source devel/setup.bash'

so all the commands will be run by just typing cat_make (or another alias name you choose)

Comment by Tiago_Dev_Br on 2022-06-29:
Thanks a lot. When i set catkin_make and source devel/setup.bash worked.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.