0
$\begingroup$

Rosanswers logo

I am following tutorials of ROS at the ROS wiki

//www.ros.org/wiki/ROS/Tutorials/ExaminingPublisherSubscriber. 

When I try to run rosrun beginner_tutorials talker. It tells me that:

[rosrun] Couldn't find executable named talker below /home/maverick/catkin_ws/install/share/beginner_tutorials

I know that the executable is not in the install folder but rather in devel. How can I make it search for rosrun beginner_tutorial talker in

devel/lib/beginner_tutorials/talker

Additional information: When I ran find -executable -type f the output is given as below:

*./devel/lib/beginner_tutorials/add_two_ints_client
./devel/lib/beginner_tutorials/talker
./devel/lib/beginner_tutorials/add_two_ints_server
./devel/lib/beginner_tutorials/listener
./devel/_setup_util.py
./devel/env.sh
./install/_setup_util.py
./install/env.sh
./build/CMakeFiles/CompilerIdC/a.out
./build/CMakeFiles/CompilerIdCXX/a.out
./build/CMakeFiles/CMakeDetermineCompilerABI_C.bin
./build/CMakeFiles/CMakeDetermineCompilerABI_CXX.bin
./build/catkin_generated/installspace/_setup_util.py
./build/catkin_generated/installspace/env.sh
./build/catkin_generated/setup_cached.sh
./build/catkin_generated/env_cached.sh*

After using the env | grep ROS_PACKAGE_PATH I get:

ROS_PACKAGE_PATH=/opt/ros/groovy/share:/opt/ros/groovy/stacks

and I have sourced the file using the following command:

source ./devel/setup.bash

Originally posted by Asfandyar Ashraf Malik on ROS Answers with karma: 729 on 2013-06-11

Post score: 10


Original comments

Comment by Boris on 2013-06-11:
Please post more info, i.e. output of $ env | grep ROS_PACKAGE_PATH. Also check whether you did source appropriate setup.bash file or not.

Comment by Asfandyar Ashraf Malik on 2013-06-11:
I have edited my question up there and have posted my output to $ env| grep ROS_PACKAGE_PATH . Also I have sourced the file using the command source ./devel/setup.bash

Comment by dornhege on 2013-06-11:
Something doesn't match. Did you source the setup.bash after the ROS_PACKAGE_PATH display? Did you run catkin_make?

Comment by Asfandyar Ashraf Malik on 2013-06-11:
Yes I did all of this. Even after this I am still getting the same errors. When I do roscd beginner_tutorials I get /catkin_ws/install/share/beginner_tutorials$. Why is roscd checking always in the install folder. It should check in the devel because my executables are there. How can I change this.

Comment by kiyamelak on 2016-06-29:
I had the same error and this is same of the things I did. 1.Delete the build and devel folder with our your working directory. 2.Make sure that all that you have followed the overall order and structure with in you CMakeList http://wiki.ros.org/catkin/CMakeLists.txt 3.Include all the package needed

Comment by M.Halwani on 2020-08-07:
I'm still having a problem saying

 [rosrun] Couldn't find executable named run_emvs below /home/ubuntu/emvs_ws/src/rpg_emvs/mapper_emvs

I followed the installation guide in here ! https://github.com/uzh-rpg/rpg_emvs

$\endgroup$

3 Answers 3

0
$\begingroup$

Rosanswers logo

The ROS_PACKAGE_PATH is wrong - it should also include the path to overlay, i.e. to your catkin workspace.

If ROS_PACKAGE_PATH didn't change after $ source ~/catkin_ws/devel/setup.bash then there is something wrong with your overlay. Try to recreate it.

UPDATE:

This tutorial may also help. In case you are using install space you have to source setup.bash from it.

At any rate it will be better to recreate workspace and try again with $ source devel/setup.sh


Originally posted by Boris with karma: 3060 on 2013-06-11

This answer was ACCEPTED on the original site

Post score: 3


Original comments

Comment by Asfandyar Ashraf Malik on 2013-06-11:
Thanks. I will try to recreate it

Comment by Abdul Mannan on 2016-11-14:
Asfandyar, did you resolve the problem. I have been following the same steps but I am unable to do that.

Comment by Abdul Mannan on 2016-11-14:
To me it seems that this method does not work.

Comment by Jägermeister on 2019-02-19:
This isn't the solution. I have both of source /opt/ros/melodic/setup.bash source ~/ros_ws/devel/setup.bash these and I still run into the same problem.

$\endgroup$
0
$\begingroup$

Rosanswers logo

i had a problem like this but when made srv and msg folder with mkdir $

 cd ~/catkin_ws/src/beginner_tutorials
$ mkdir msg

and

$ roscd beginner_tutorials
$ mkdir srv

look at this link and then run catkin_make and did every thing for talker.cpp and listener.cpp and did source ./devel/setup.bash in my catkin workspace and run catkin_make again and we could see :

Linking CXX executable /home/fatima/catkin_ws2/devel/lib/beginner_tutorials/talker
Linking CXX executable /home/fatima/catkin_ws2/devel/lib/beginner_tutorials/listener

and then : two executable file were made in catkin_ws/devel/lib/beginner_tutorials/talker and listener and now it could be run :

rosrun beginner_tutorials talker

Originally posted by fatima with karma: 62 on 2015-12-11

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$
0
$\begingroup$

Rosanswers logo

you should grant execute permission to the file

chmod +x exec_file

Originally posted by tsadik with karma: 91 on 2017-03-06

This answer was NOT ACCEPTED on the original site

Post score: 7


Original comments

Comment by Btdr on 2018-08-16:
Specifically created an account to upvote. Thank you!

Comment by Jägermeister on 2019-02-19:
Where is this file?

Comment by parzival on 2019-08-16:
replace exec_file with your file name

Comment by Nooyi on 2020-05-04:
this worked! thank you so much!!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.