0
$\begingroup$

Rosanswers logo

So I have two machines #1 and #2. I selected #1 as the master by

$ ssh #1
$ roscore

Now I opened a new terminal on #1 and then

$ export ROS_MASTER_URI=http://#1:11311
$ rosrun test1 listener

(Now the terminal is halting, waiting for messages to be posted on the topic)

Now I go on machine #2 and

$ ssh #2
$ export ROS_MASTER_URI=http://#1:11311
$ rosrun test2 talker

(The "Helloworld x" pops up continuously with incrementing x)

When I look at #1, the listener is still halting, I should expect "heard x" with incrementing x. If I try the two nodes on each machine, they work perfectly fine. It is just when I now use two machines.

Btw, they are in the same wireless network and I already check the network setup as in the ROS tutorial.

Could anyone solve my problem? Thanks.


Originally posted by Bholms on ROS Answers with karma: 83 on 2013-06-08

Post score: 1


Original comments

Comment by GeneralSpoonFul on 2013-11-02:
I have the same problem and setting the ROS_IP and ROS_HOSTNAME did not do it for me...

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Most probably you forgot to specify ROS_IP or ROS_HOSTNAME environment variables to make it work. From the manual:

With the exception of 'localhost', it does not affect the actual bound address as ROS components bind to all available network interfaces. If the value is set to localhost, the ROS component will bind only to the loopback interface. This will prevent remote components from being able to talk to your local component.


Originally posted by Boris with karma: 3060 on 2013-06-08

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.